NConvert on webserver [Debian Linux]

Questions, suggestions, and answers for XnView on all Un*x platforms (Linux, HP-UX, AIX, ...)

Moderators: XnTriq, xnview

Post Reply
AceMan
Posts: 1
Joined: Fri Apr 13, 2007 5:36 pm

NConvert on webserver [Debian Linux]

Post by AceMan » Fri Apr 13, 2007 5:46 pm

Hi,

I am total newbie if it comes about Linux, but the thing is that I have Debian Linux on my server where I keep my webpages and I need to run NConvert on it.

So, I copied the Linux x86 version on my server and tried to launch it via Putty. But it showed that:

Code: Select all

./nconvert: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
So, I asked my Linux friends if they could send me that library. I got it and tried again. Then, a new alert:

Code: Select all

./nconvert: /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./libstdc++.so.6)
./nconvert: /lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by ./libstdc++.so.6)
So, I asked them again and they sent me these libraries. And again, I tried to launch nconvert...

But this message appears everytime:

Code: Select all

./nconvert: /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./libstdc++.so.6)
I don't have a clue where I can find this lib in this version...

Please help me and provide some links to that version of that library or maybe a nconvert version that doesn't require such libs.

Thanks in advance.

User avatar
xnview
Author of XnView
Posts: 31747
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: NConvert on webserver [Debian Linux]

Post by xnview » Mon Apr 16, 2007 7:01 am

AceMan wrote:

Code: Select all

./nconvert: /lib/libc.so.6: version `GLIBC_2.4' not found (required by ./libstdc++.so.6)
If your friends have libstd++, they must have libc too
Pierre.

Post Reply