Thank you for raising the issue which keeps confusing people.
The problem is partly the naming but also the separation of this menu item from the other "Zoom" menu items and last not least the expectation people have: More or less it is good to have a automatic zoomed image when zooming from one image to the next. And the user thinks that he/she has found this handy feature in the menu "auto image size".
"Auto image size" has never sounded very clear to me, I'd like to see a label that contains "Zoom" since these settins are nothing else than special, automatically calculated zoom settings. Some possible names:
"Zoom & Fit"
When looking at the sub menu items in "Auto image size" I find that the labels of the menu items are long and clear. They could be shorter and even a bit clearer.
I've grouped the menu items using separators and changed the order a bit. And I have removed the additions ",all" since this is clear.
Proposal B: "
Normally, it's better to be a bit verbose, but if menu texts are too long, it's harder to understand at first glance. The hard thing is to find a good balance between length and clearliness. Basically, Zooming and fitting is for images, so I've removed the word "image". I've changed "large only" to "large images only". All in all the length of the menu items remained the same, but to me this seems a bit clearer.
I've replaced the term "Fit" by "Zoom" to emphasize that we speak of zooming.
Currently, my favourite is A, the simple changes are sufficient. And "No fit" should be removed.
- Remove "No fit"?!
At the moment I'm not clear why we need "No fit" in this menu. "No fit" makes sense in the options, but not in the "View" menu. If the user does want other zooms than dynamic zoom, he/she can use one of the many other menu items for zooming. And in "Options" the term "No fit" should be replaced by something like "100%" or "No fit (100%)".
- Options: Same thing, but permanent
Remains the naming in the "Options" dialog. The thing is the same, the only difference is that one is for the current image and the other one is when opening an image. For this reason I think a similar term should be used, by adding "always" or another word this aspect might be emphasized. E.g. "Zoom fit (always):"