File associations not set properly on Windows 8

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
User avatar
Attacker
Posts: 10
Joined: Wed Oct 22, 2008 11:33 am
Location: China

File associations not set properly on Windows 8

Post by Attacker » Tue Dec 25, 2012 10:59 am

In Windows 8, set file association with XnView is no enough
Even if I've set the file association, when I double click an image file, Windows 8 will show a menu and I have to choose XnView for the defaut program for this file type.
That means .bmp, .jpg, .gif, .png...each type I have to set XnView as default program once

So I hope XnView can add a function that can set it self as the default image viewer in Windows 8
For example, Media Player Classic - Home Cinema has added this feature in ver 1.6.5.6366
无标题.jpg
无标题.jpg (129.06 KiB) Viewed 108828 times
Image

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: When will XnView fully support Windows 8

Post by xnview » Thu Dec 27, 2012 2:24 am

ok i'll check
Pierre.

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: When will XnView fully support Windows 8

Post by xnview » Fri Mar 08, 2013 10:17 am

Attacker wrote:In Windows 8, set file association with XnView is no enough
I think that you use the ZIP package? I've tried the EXE setup and i can change associations with windows

I've tried Media Player Classic, but 'set default programs' is greyed??
Pierre.

User avatar
Attacker
Posts: 10
Joined: Wed Oct 22, 2008 11:33 am
Location: China

Re: When will XnView fully support Windows 8

Post by Attacker » Fri Mar 08, 2013 1:20 pm

xnview wrote:
Attacker wrote:In Windows 8, set file association with XnView is no enough
I think that you use the ZIP package? I've tried the EXE setup and i can change associations with windows

I've tried Media Player Classic, but 'set default programs' is greyed??
Yes, I am using ZIP package
But what I mean is that in Windows 8 set file association is not enough
After set files associations, users still need to set the software as default program
For example, I have set .jpg with XnView, then when I double click a .jpg file in Windows Explorer, there will come out a window and let me choose the default program for .jpg file

You can also see such option in installing Adobe Reader
Image

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: When will XnView fully support Windows 8

Post by xnview » Fri Mar 08, 2013 1:22 pm

could you send me your email by PM, i would like to send you a test version?
Pierre.

User avatar
Attacker
Posts: 10
Joined: Wed Oct 22, 2008 11:33 am
Location: China

Re: When will XnView fully support Windows 8

Post by Attacker » Tue Mar 12, 2013 4:34 pm

xnview wrote:could you send me your email by PM, i would like to send you a test version?
Nice, it works, great
I can set XnView as default program in Control Pannel
But isn't the file types of XnView in Control Pannel so few?
QQ截图20130313003806.jpg
QQ截图20130313003806.jpg (81.56 KiB) Viewed 108343 times
And I hope the description of XnView in Control Pannel can be localized :D
无标题.jpg
无标题.jpg (125.45 KiB) Viewed 108343 times
Image

mimorqleko
Posts: 5
Joined: Tue Mar 12, 2013 9:23 pm

Re: When will XnView fully support Windows 8

Post by mimorqleko » Tue Mar 12, 2013 9:30 pm

Yeah, actually there are quite a few file associations to choose in Default Programs.
Even MS Paint has more default associations than Xnview.

I hope Pierre can fix this, I love the app!!! :D

Trititaty
Posts: 2
Joined: Tue Feb 18, 2014 1:19 pm

Re: File associations not set properly on Windows 8

Post by Trititaty » Tue Feb 18, 2014 1:41 pm

Yep, there are only 32 formats to associate with XnView in Windows 8 while the built-in viewer has 43.

UPD. It seems I've got 32 only after playing with compatibility options. But this is dirty.

Trititaty
Posts: 2
Joined: Tue Feb 18, 2014 1:19 pm

Re: File associations not set properly on Windows 8

Post by Trititaty » Thu Feb 20, 2014 7:31 am

SOLUTION

To get more formats to associate with XnView use one of the following reg files:
• 64-bit Windows 8, essential format associations: xnview_associate_win8x64_essentials.reg
• 32-bit Windows 8, essential format associations: xnview_associate_win8x86_essentials.reg
• 64-bit Windows 8, all supportable format associations: xnview_associate_win8x64_everything.reg
• 32-bit Windows 8, all supportable format associations: xnview_associate_win8x86_everything.reg

Instructions.
1. Make sure that you choose the right type: x64 and x86 versions aren't interchangeable.
2. Make sure that XnView is installed to its default path "C:\Program Files (x86)\XnView" (for 64-bit) or "C:\Program Files\XnView" (for 32-bit). Otherwise you should replace all paths in the reg file with yours (remembering the doubling backslashes).
3. You should prefer "essential formats" version unless you really need some other formats.
4. Download a corresponding reg file according to your OS bitness then double click it and agree.
5a. If you have chosen "essential formats" version just go to Control Panel and associate all newly appeared formats (or just some of them as you wish) with XnView.
5b. If you have chosen "all formats" version go to Control Panel but avoid assigning all the available formats to XnView since it may cause problems. Just check those ones you really use.

Note. By "essential formats" I mean "The most used" ones as they called in previous versions (when we could choose associations within XnView) plus formats associated with Windows 8 Photos application (that one with Metro UI). Thus you can override Photos' associations with XnView and forget about it.

And one last thing. If you uninstall XnView you will need this reg file: xnview_unassociate_win8x86x64.reg which kills all the XnView associations since uninstaller won't do that for you. This file is suitable both for 64-bit and 32-bit.

P.S. I hope our honoured developer will fully fix this issue so we won't need my monstrous workaround anymore.

Post Reply