ListViewHeight and PreviewHeight in .ini-file not respected

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
User avatar
klapperstorch
Posts: 49
Joined: Fri Jan 26, 2007 8:43 am

ListViewHeight and PreviewHeight in .ini-file not respected

Post by klapperstorch » Mon Dec 02, 2013 10:48 am

Recently I moved from WinXP to Win7 and installed XnView 2.05 on the new system.
Now I notice a behaviour in the Browser that I did not have with WinXP:
When I resize the ListView and PreviewView fields by moving the separation line, this new setting is written to the .ini-file (ListViewHeight and PreviewHeight). I can see the new values in it.
But after a restart XnView has returned to its previous setting. And after stopping it the old values have been written back to the .ini-file.
Other information in the .ini-file (like files or directories recently used) is available after a reload of XnView. So, a problem with writing to and reading from the .ini-file cannot be the problem.

What may be the cause for not respecting my settings for ListViewHeight and PreviewHeight?

User avatar
xnview
Author of XnView
Posts: 33166
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: ListViewHeight and PreviewHeight in .ini-file not respec

Post by xnview » Mon Dec 02, 2013 7:42 pm

Which layout do you use? You had same version before?
Pierre.

User avatar
klapperstorch
Posts: 49
Joined: Fri Jan 26, 2007 8:43 am

Re: ListViewHeight and PreviewHeight in .ini-file not respec

Post by klapperstorch » Tue Dec 03, 2013 8:56 am

Pierre, I use the 4th layout: directories on the left, listview and preview on the right, with listview on top.
In WinXP (which I have still running on another PC) I have installed XnView 1.98.2. In Win7 it is 2.05.

I just installed 1.98.2 on Win7 to test. The result is the same as with 2.05: the ListViewHeight and PreviewHeight changes are lost when XnView is started again.
I also installed 2.05 on the WinXP system: There this version of XnView behaves as it should: the changes of the field sizes are kept across new starts of XnView.
Therefore it is not a difference in the XnView versions, it must have something to do with the migration from WinXP to Win7.
I don't think that reading of the .ini-file has some failure because other changes in XnView, such as recently used directories etc., are kept across XnView restarts.
May be in Win7 the controls for elements in an application window have changed. And if this true, other controls which XnView uses, may also work incorrectly in Win7.

User avatar
klapperstorch
Posts: 49
Joined: Fri Jan 26, 2007 8:43 am

Re: ListViewHeight and PreviewHeight in .ini-file not respec

Post by klapperstorch » Wed Dec 04, 2013 8:57 am

I performed some more tests by moving other separation lines: the ListViewWidth and ListWidth changes were preserved across XnView restarts.
It's only the ListViewHeight and PreviewHeight which are reset to the same initial size at every start of XnView.

User avatar
xnview
Author of XnView
Posts: 33166
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: ListViewHeight and PreviewHeight in .ini-file not respec

Post by xnview » Thu Dec 05, 2013 9:37 am

i can't reproduce, if i change the preview height, next i'll have the good height
Pierre.

User avatar
klapperstorch
Posts: 49
Joined: Fri Jan 26, 2007 8:43 am

Re: ListViewHeight and PreviewHeight in .ini-file not respec

Post by klapperstorch » Thu Dec 05, 2013 11:02 pm

Thank you, Pierre. Your answer told me that it could not be a general problem with Windows 7. So I did some more testing.
Interesting was, that XnView in the Administrator account behaved properly. Therefore I created a testuser account. In the new account then, the described problem did not appear.
This led me to the conclusion that there must be something wrong with the XnView configuration files in C:\Users\USERNAme\AppData\Roaming\XnView\. To make it short, I saved all files in this folder, copied the files from my testuser into it, and the problem was gone. After copying back the "bad" files, the problem was there again.
Then I concentrated my further research on xnview.ini and compared the "good" ini with the "bad" ini. Of course, there were a lot of differences, but after copying the differing lines block by block from the "bad" ini to the "good" ini and testing everytime, I was finally able to locate the culprit:
It is the definition "Height=" in section [Start]. In the "bad" ini I have "Height=346", in the "good" ini it is "Height=810". When I change the "good" ini to "Height=346" I have the same problem with it. When I change the "bad" ini to "Height=810" it is no longer bad. I don't know how the bad value came to this Height-parameter. I will leave this to your imagination.

With best regards, klapperstorch

P.S. A last remark: I use a monitor with full HD-resolution (1920x1080 pixels) and XnView window maximized. I tell you this, just in case you want to recreate the problem and it depends on window size.

User avatar
xnview
Author of XnView
Posts: 33166
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: ListViewHeight and PreviewHeight in .ini-file not respec

Post by xnview » Fri Dec 06, 2013 8:46 am

klapperstorch wrote: It is the definition "Height=" in section [Start]. In the "bad" ini I have "Height=346", in the "good" ini it is "Height=810". When I change the "good" ini to "Height=346" I have the same problem with it. When I change the "bad" ini to "Height=810" it is no longer bad. I don't know how the bad value came to this Height-parameter. I will leave this to your imagination.
Yes strange, that this value was not modified
Pierre.

Post Reply