Scanner is working, but no longer in "Select Twain Source"

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

User avatar
XnTriq
Moderator & Librarian
Posts: 5496
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by XnTriq » Sat May 03, 2014 2:30 pm

These reports sound promising:
Gene E. Bloch (alt.windows7.general » [url=http://www.pcbanter.net/showthread.php?p=3584561#post3584561]TWAIN suddenly requires admin privileges[/url]) wrote:I finally found FILE NAME CONFLICT or something like that related to Twain, referring to two files in my AppData\Local\Temp folder. I killed them, and voilà! I can now scan without running as Admin.

The files were TWAIN.LOG and Twain001.Mtx, and they apparently served as locks to prevent simultaneous access to Twain from (something).
DC (alt.comp.periphs.scanner,comp.periphs.scanners » [url=http://www.tomshardware.co.uk/forum/20618-3-epson-scan-fails-load-perfection-3170#210858]Epson Scan Fails to Load for Perfection 3170[/url]) wrote:I did however manage to fix the problem through further deliberate correspondence with Epson. I'll outline what they suggested here in case anyone else experiences this problem in the future.
  1. uninstall the scanner from the Device Manager and uninstall Epson Scan from the Add/Remove Program control panel. (did this part before)
  2. search for and remove any of the follow files from the HD:
    Twain.log, Twain001.mtx, Twunk001.mtx, Twunk002.mtx, Twunk003.mtx
  3. remove the Epson directory from C:\WINDOWS\TWAIN_32\
  4. remove the Epson Scan group from the Windows registry under both
    HKEY_LOCAL_MACHINE\Software\Epson\
    HKEY_CURRENT_USER\Software\Epson\
  5. reboot and reinstall Epson Scan
Please go to your system's %Temp%/%Tmp% folder (%SystemDrive%\Users\{username}\AppData\Local\Temp) and delete these files:
  • TWAIN.LOG
  • Twain001.Mtx
  • Twunk001.MTX
  • Twunk002.MTX

User avatar
windbag
Posts: 27
Joined: Mon Jan 16, 2012 10:33 am

Re: Scanner is working, but no longer in "Select Twain Sourc

Post by windbag » Thu May 15, 2014 2:04 pm

I had dreaded doing anything more when the "Epson eradication" process thread was cited.
I've had to do a few such things in the past, they've always "put me in detention" for hours and the instruction failure rate was about 80%.
That thread didn't improve that score.
When I got to this bit:
5. Click Start and type "APPDATA" in the Start Search window.
1. Select APPDATA from the list under programs.
2. Open the folder called "Local" and then open the folder called "Temp"

I couldn't, because I run VistaStartmenu, which overrides the normal "start button" function.
So finding A PC not running it, I find it still doesn't work;
What "list under programs" ? - so nothing to pick APPDATA from.

If it was a rather cumbersome way of navigating to User/Appdata/Local/Temp, the the next direction:

3. Select all items in this folder and press delete on the keyboard.

was too dangerous for me.
It may say "Temp", but there was 3GB of data about reams of programs in there!

So I didn't. But I did uninstall the Epson, plus the Epson Scan software, but also the Epson Smart Panel, Photo Print and Copy Utilities.

Then I did find those four files, deleted (just) them and re-started.

Then, of course, I couldn't find the Epson Installation disc. Actually, not "of course" - I rarely lose such, but this one is AWOL, despite a protracted search. By which time I had to leaved the process for the day.

Day 2, and the quest for finding the Epson 1670 scan/driver installation software for Vista 32bit.

I found V3.04A on the USA site, dated 29/7/2008. Installed rebooted and - nothing. No difference to XnV 2.2 standalone, my v1.99.6 or Corel Draw. No Twain sources.

Then I found that there was a totally different Epson scan/driver installation package on the European site:
http://esupport.epson-europe.com/Produc ... U003D&tc=6
V3.0, dated 25/2/2010 Eh??
So I downloaded it, re-deleted those files, used this install package.
It certainly installed with different dialogue screens, and was for three different scanner models (you had to select), and ended with the forced restart.

After installation, I note Device Manager/properties reports it as actually V3.0.4 28/12/2006 !
So maybe actually the same (didn't look after the USA version failed).

But: LO!
XnV 2.2 found, not only the Epson 1670, but my Brother MFD & a host of other.
YO!
It also fired up Epson Scan correctly. Double YO!
Over to Corel Draw. Ditto.
Finally, fire up desktop XnV1.99.6.
SUCCESS!
XnTriq wrote:.....Please go to your system's %Temp%/%Tmp% folder (%SystemDrive%\Users\{username}\AppData\Local\Temp) and delete these files:
  • TWAIN.LOG
  • Twain001.Mtx
  • Twunk001.MTX
  • Twunk002.MTX
I have a feeling that all I had to do was delete those 4 files at the start & reboot, and it would have all worked.
Unfortunately I had uninstalled the device & all the software before I came to that, so will never know.
why the USA install didn't work I don't know (did I fail to delete TWAIN.LOG ? Possibly).

Anyway, my XnV-Epson combo is now back & running - so thanks for staying with me.

Post Reply