Page 1 of 1

XnView has stopped working - loading 25,000 jpgs

Posted: Sun Feb 14, 2016 9:41 pm
by appyface
I use XnView to browse still captures (.jpg) from my security cameras, I can skim through very quickly and stop to play video only if something is of interest. XnView's many sorting options make it my preferred tool for this job. Thank you!

Now the bad news. Often I am unable to use XnView. Apparently because the number of captures is too high?

I get a message while the thumbnails are loading:

"XnView for Windows has stopped working.
Windows is checking for a solution to the problem..."

Followed by this message:

"XnView for Windows has stopped working.
A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."

There is another freeware program, Vallen JPegger, that I switch to using when XnView won't finish loading the captures. JPegger is a very nice program in it's own right, but it lacks the robust sorting of XnView, so when I have to use it for this purpose I spend a lot more time reviewing. XnView is definitely a time saver for this task.


I checked, "Use high quality" is unmarked in Options.

Caching was on, so I turned it off and emptied it. With it off, more thumbnails load and faster, but XnView still stops before it can finish a high number.

CPU and memory do not seem exceptional when XnView stops working. CPU for XnView is around 47% with around 80% total utilization (E6850 3ghz Core2 Duo). 6 Gig memory (Win7 Pro SP1 64-bit) that climbs from 2.0G to 3.8G at the time XnView stops working. I'm looking at Process Explorer by Windows Sysinternals for these figures.

A side note. Some time back I put in a feature request for a date-range with time-range (e.g. date/time-from through date/time-to), please forgive a shameless plug now for my suggestion :-) That suggestion came out of this situation. My thought was with that feature, I could browse smaller groups of captures at a time and get through them that way.

Please let me know what else I can check or I can do? Thank you for any help.

Kind regards,
--appyface

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 15, 2016 11:06 am
by xnview
XnView is a 32bits app, so your 6gigs will not be used. Please check XnView MP 64bits

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 15, 2016 12:50 pm
by appyface
xnview wrote:XnView is a 32bits app, so your 6gigs will not be used. Please check XnView MP 64bits
Thank you, I will!

I have 24G swap file in addition to 6G physical memory. Will XnViewMP, being on a 64bit system, be able to also use the swap file to extend its capacity? Or will it still only use physical memory available?

Thank you again for your help.
Kind regards,
--appyface

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 15, 2016 1:45 pm
by xnview
if the system tells to XnView that you have always memory (ram or swap), XnView MP will use it

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 15, 2016 2:33 pm
by appyface
I've almost got XnViewMP behaving like XnView did, but still struggling with a couple of things?

1. I'm not able to select Filter by -> Images. I can select "all" or "custom". So, I deselected everything except images in the filter in settings. Now only folders and images are being displayed. In XnView, only images display, no folders. This causes no issue for me, just wondering how to fix it.

2. I have a lot of horizontal border around images displayed after a search. I set all border widths I could find to 0, and removed the display of tag, star, circle. But still there is a lot of space on either side of the images. (Vertical spacing is fine once I changed the display to just the filename.) How do I shrink the border on either side of the image to minimal spacing?

Thank you

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 15, 2016 9:33 pm
by xnview
appyface wrote: 1. I'm not able to select Filter by -> Images. I can select "all" or "custom". So, I deselected everything except images in the filter in settings. Now only folders and images are being displayed. In XnView, only images display, no folders. This causes no issue for me, just wondering how to fix it.
Yes folder are displayed now with Images. But you can use a custom filter (settings>filelist>Custom filter)
2. I have a lot of horizontal border around images displayed after a search. I set all border widths I could find to 0, and removed the display of tag, star, circle. But still there is a lot of space on either side of the images. (Vertical spacing is fine once I changed the display to just the filename.) How do I shrink the border on either side of the image to minimal spacing?
could you post a screenshot?

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Tue Feb 16, 2016 2:39 am
by appyface
xnview wrote:Yes folder are displayed now with Images. But you can use a custom filter (settings>filelist>Custom filter)
Yes I have custom filter set to just images, nothing else, and still see the folders too. Again, not an issue, just curious if I can make it like XnView (no folder display).
xnview wrote:could you post a screenshot?
20160215-182623_XnViewMP.png
Horizontal space between images

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Tue Feb 16, 2016 8:30 am
by xnview
in XnView Classic, you are able to reduce this space?
perhaps by growing the height of your thumbnails?

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Tue Feb 16, 2016 10:23 am
by appyface
My goal is somewhat different than that...

As I am using XnView to quickly scan my security camera images, my goal is always to find a large enough size for viewing, that I can fit in static positions on the screen page size. Then I can arrow down through the images quickly to 'scan' them for scene changes.

When I have XnView set this way, the physical placement of the images on the screen page doesn't change as the images do while moving through, and scene changes are fairly easy to notice.

I have the same custom size thumbnails in both XnView and XnView64 right now, and both have three across and nine down with the horizontal spacing very similar to the XnVieMP screenshot above.

This is Vallen Jpegger, the thin horizontal spacing border shown is what I'm after in XnView/XnViewMP:
20160216-015048_Vallen JPegger.png
Vallen JPegger Horizontal Spacing
The thumbnails are nearly the same size as I have in XnView/XnViewMP, but I can fit four across in JPegger due to the thin border in between the images. Unfortunately JPegger is harder to use than XnView as I have less control on the vertical spacing and static image placement options on the displayed page.

Ultimately if pictures are close together with a thin border I gain a bit more flexibility for larger or more images on a static grid position.

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Sat Feb 20, 2016 2:47 am
by appyface
In XnView, when I bring up the search box and enter (for example) 11*.* in the filename box, the images are restricted to those filenames that start with 11, which is what I want (and expected).

In XnViewMP, when I put the same criteria 11*.* in the filename box in the search panel, it brings back all with an 11 somewhere in the filename. (RegEx box is not checked.)

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 22, 2016 9:01 am
by xnview
By changing thumbnail size, i'm able to have something similar as Jpegger screenshot.

Re: XnView has stopped working - loading 25,000 jpgs

Posted: Mon Feb 22, 2016 8:56 pm
by appyface
That hasn't been the answer for me so far but I'll play with it a bit more. Thank you.