Webp doesn't work 2.48

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

Post Reply
User avatar
egaskrad
Posts: 4
Joined: Wed Sep 11, 2019 1:01 am

Webp doesn't work 2.48

Post by egaskrad » Wed Sep 11, 2019 1:19 am

Downloaded webp files from the following link
https://developers.google.com/speed/webp/gallery1

The webp files open in Chrome, Firefox, Windows Explorer as thumbnail, Faststone, GIMP, etc.

The webp files do not open in XnView Classic for Windows 2.48. When I load the directory holding the files in XnView Classic for Windows 2.48, the thumbnails of the webp files show. However when I select one of them, the image does not show up in the preview panel. When I double click the file, a windows box shows up. It says "How do you want to open this file?" and passes me a list of apps on my computer, defaulted app is Chrome.

My system: Windows 10 Pro, 10.0.11763 (latest), x64-based PC.


Does it means that I need Webp 64 support to make it work and Webp 32 just won't do it? I thought Webp 32 is a format.

User avatar
xnview
Author of XnView
Posts: 32045
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Webp doesn't work 2.48

Post by xnview » Wed Sep 11, 2019 7:18 am

please try to download the 2.49, do you have Plugins/libwebp.dll?
Pierre.

User avatar
egaskrad
Posts: 4
Joined: Wed Sep 11, 2019 1:01 am

Re: Webp doesn't work 2.48

Post by egaskrad » Thu Sep 12, 2019 12:30 am

1) No, my 2.48 Standard did not have libwebp.dll in the plugin folder.

2) I have downloaded 2.49.1 FULL. I have double checked. It has libwebp.dll in the plugin folder.

3) It is working now. So the standard xnview doesn't have it, huh... but the thumbnails worked... I thought webp is something as common as png...

Post Reply