TIFF : Bad bits per sample!

Ask for help and post your question on how to use XnView Classic.

Moderators: XnTriq, xnview

w64bit
Posts: 18
Joined: Sat Feb 07, 2015 9:33 pm

TIFF : Bad bits per sample!

Post by w64bit »

When I try to view some TIF files (created with a large format scanner) with 2.49.4 I receive the error:
TIFF : Bad bits per sample!
1. How can I fix these files without losing the quality?
2. How can I find other TIF files with the same problem (an automatic/search method)?
Thank you
w64bit
Posts: 18
Joined: Sat Feb 07, 2015 9:33 pm

Re: TIFF : Bad bits per sample!

Post by w64bit »

2.49.3 it's OK.
I think that the problem it's related to TIFF Security vulnerability fix in 2.49.4.
User avatar
xnview
Author of XnView
Posts: 36320
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: TIFF : Bad bits per sample!

Post by xnview »

could you send me the file?
Pierre.
w64bit
Posts: 18
Joined: Sat Feb 07, 2015 9:33 pm

Re: TIFF : Bad bits per sample!

Post by w64bit »

I noticed also that if you browse the folder containing these type of files, they are briefly displayed in the right pane and after that they disappear.
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 36320
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: TIFF : Bad bits per sample!

Post by xnview »

w64bit wrote: Tue Nov 10, 2020 3:23 pm I noticed also that if you browse the folder containing these type of files, they are briefly displayed in the right pane and after that they disappear.
Right, i'll fix it
Pierre.
User avatar
Peter2
XnThusiast
Posts: 1270
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Re: TIFF : Bad bits per sample!

Post by Peter2 »

Fixed in version 2.49.5, Feb 02, 2021
XnView 2.50.2 German, Win 10