AVIF support in xnview Classic?

Ask for help and post your question on how to use XnView Classic.

Moderators: helmut, XnTriq, xnview

digiformer
Posts: 7
Joined: Wed Sep 28, 2016 10:39 am

AVIF support in xnview Classic?

Post by digiformer »

Hello there,

AVIF is listed in the list of supported formats for classic version 2.50.
I cant get it to work.
I also installed the PSD-Plugin in the 8bi folder, but it seems not to be recognized...
(i tried 32-bit and 64-bit)

What do i do wrong?

Kind Regards
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: AVIF support in xnview Classic?

Post by xnview »

AVIF is only supported on XnView MP 64bits
Pierre.
digiformer
Posts: 7
Joined: Wed Sep 28, 2016 10:39 am

Re: AVIF support in xnview Classic?

Post by digiformer »

Ok... :(

No chance to "paste" the code into a later release? :wink:

You might consider taking it off the supported formats list on Your website...

Kind regards
Dante_1880
Posts: 3
Joined: Mon Aug 15, 2022 6:49 am

Re: AVIF support in xnview Classic?

Post by Dante_1880 »

Hello,

I don't understand WHY avif files can't be viewed with XNVIEW CLASSIC 64b.

I have configured XNVIEW CLASSIC with my preferences. After configuring it with my preferences, now I have to configure another program of XNVIEW again with my preferences, again. XNVIEUW MP 64b seems harder to "look at" and it's not possible to configure.

I just have a question and I can't imagine an answer for it, WHY avif files can't be viewed with XNVIEW CLASSIC?

Thank you.
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: AVIF support in xnview Classic?

Post by xnview »

Dante_1880 wrote: Mon Aug 15, 2022 6:59 am I just have a question and I can't imagine an answer for it, WHY avif files can't be viewed with XNVIEW CLASSIC?
why you don't use XnView MP?
Pierre.
digiformer
Posts: 7
Joined: Wed Sep 28, 2016 10:39 am

Re: AVIF support in xnview Classic?

Post by digiformer »

As for me: I have only Classic licenses...
cday
XnThusiast
Posts: 3351
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: AVIF support in xnview Classic?

Post by cday »

I believe it is still the same licence for Classic and 'MP: License compatibility for MP and Classic... :D
digiformer
Posts: 7
Joined: Wed Sep 28, 2016 10:39 am

Re: AVIF support in xnview Classic?

Post by digiformer »

oh wow... i actually do read licensing information and i saved in my mind that this would not be the case. But if this is wrong... fine

@ pierre: Can you confirm that for today and the future?

kind Regards
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: AVIF support in xnview Classic?

Post by xnview »

digiformer wrote: Tue Aug 16, 2022 10:58 am @ pierre: Can you confirm that for today and the future?
yes 1 license allows to use XnView Classic and/or XnView MP
Pierre.
Dante_1880
Posts: 3
Joined: Mon Aug 15, 2022 6:49 am

Re: AVIF support in xnview Classic?

Post by Dante_1880 »

I use XnView 2.51.0 CLASSIC Free for Windows 10 (no license use), but it doesn't read AVIF, why?

https://www.xnview.com/en/image_formats/


XnView 2.51.0 CLASSIC Free for Windows 10
Extended
The extended version includes
Languages: All languages
Plugins & Addons: All
Extras: NConvert, ShellEx, Media Detector.

Thank you.
User avatar
xnview
Author of XnView
Posts: 38288
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: AVIF support in xnview Classic?

Post by xnview »

Dante_1880 wrote: Thu Aug 18, 2022 12:50 am I use XnView 2.51.0 CLASSIC Free for Windows 10 (no license use), but it doesn't read AVIF, why?
AVIF is only available as 64bits plugin
Pierre.
aboy
Posts: 4
Joined: Tue Mar 05, 2019 7:04 pm

Re: AVIF support in xnview Classic?

Post by aboy »

To view AVIF in XnView you can try Susie plugins
One
Two (HEIF/AVIF)

Also JXL just in case

Pierre:
Also for some reason XnView's plugin for Susie plugins (Xsusie.dll) contains wrong data in version info section from another plugin:

Code: Select all

"CompanyName", "XnView"
"FileDescription", "XnView JPEG-LS plugin"
"FileVersion", "1.90 beta 3 (unstable)"
"InternalName", "JPEG-LS plugin"
"OriginalFilename", "jpeg_ls.DLL"
"ProductName", "XnView JPEG-LS plugin"
"ProductVersion", "1.90 beta 3 (unstable)"
Looks like something was messed in sources or while compiling.
Not a big deal but anyway