Illustrator thumbs don't work anymore

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
Troken
Posts: 698
Joined: Thu Feb 09, 2006 10:18 am
Location: Sweden

Illustrator thumbs don't work anymore

Post by Troken » Wed Jan 10, 2007 2:51 pm

With RC1 the thumbnails of Adobe Illustrator-files won't show, they're just program icons. Anyone else encountered this?

Yes, I have GhostScript and it works fine in all versions before RC1.

V 1.90 RC1

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: Illustrator thumbs don't work anymore

Post by xnview » Wed Jan 10, 2007 4:24 pm

Troken wrote:With RC1 the thumbnails of Adobe Illustrator-files won't show, they're just program icons. Anyone else encountered this?

Yes, I have GhostScript and it works fine in all versions before RC1.
And the load works?
Pierre.

User avatar
Troken
Posts: 698
Joined: Thu Feb 09, 2006 10:18 am
Location: Sweden

Re: RC1: Illustrator thumbs don't work anymore

Post by Troken » Wed Jan 10, 2007 5:35 pm

xnview wrote:And the load works?
The load? Since I don't know what load you mean I made following tests:

pressing F3 - loading file in editor works fine.
singlelclick - preview only shows hex-code or what it is, no image.
doubelclick - the statusbar at the lower end loads to max but then nothing more happens.

User avatar
xnview
Author of XnView
Posts: 33425
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: Illustrator thumbs don't work anymore

Post by xnview » Wed Jan 10, 2007 6:20 pm

Troken wrote:
xnview wrote:And the load works?
The load? Since I don't know what load you mean I made following tests:

pressing F3 - loading file in editor works fine.
singlelclick - preview only shows hex-code or what it is, no image.
doubelclick - the statusbar at the lower end loads to max but then nothing more happens.
Ok, could you send me a sample, please?
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Same for…

Post by Clo » Wed Jan 10, 2007 7:39 pm

—> Troken

:) Hello !

• Please, give a glance HERE, the tumb nails follow exactly the images, I tested too …

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

User avatar
Troken
Posts: 698
Joined: Thu Feb 09, 2006 10:18 am
Location: Sweden

Re: RC1: Illustrator thumbs don't work anymore

Post by Troken » Wed Jan 10, 2007 9:28 pm

xnview wrote:Ok, could you send me a sample, please?
Filesample? No purpose I think, it doesn't work with ANY of my .ai-files, and it've always worked before, since I started with XnView in version 1.82.something. I would just send you perfectly fine files.

-> Clo, they don't work for you either?

EDIT: Tested the files from the other Illustrator-thread and "test_v8.ai" works fine :? Not the other two though.

User avatar
helmut
Posts: 8214
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Same for…

Post by helmut » Thu Jan 11, 2007 12:01 am

Clo wrote:• Please, give a glance HERE, the tumb nails follow exactly the images, I tested too …
Good that you have made the link between the two related or even similar topics, Clo.

User avatar
AndreaK
Posts: 4
Joined: Wed Jul 29, 2020 7:34 pm

Re: Illustrator thumbs don't work anymore

Post by AndreaK » Wed Jul 29, 2020 7:53 pm

Hi, I am totally new to XnView Software -- I downloaded it today, so that I can view Affinity Photo thumbs which do not show in Adobe Bridge. The Affinity thumbs can be successfully viewed, however now I cannot preview AI file thumbs, I only see the AI program icons. I know this has been discussed before but that was in 2007, so I am hoping I have just missed the solution somewhere in the thread. Sorry if my question is redundant... I am not really so thrilled about having to download some third-party app to make it work, I am hoping it's just a setting I need to turn on in XnView. Any thoughts? Thanks in advance.

cday
XnThusiast
Posts: 2455
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Illustrator thumbs don't work anymore

Post by cday » Wed Jul 29, 2020 8:03 pm

Do you have Ghostscript installed?

User avatar
AndreaK
Posts: 4
Joined: Wed Jul 29, 2020 7:34 pm

Re: Illustrator thumbs don't work anymore

Post by AndreaK » Wed Jul 29, 2020 8:08 pm

Hi, no I don't. Is it necessary to download it in order to view the AI thumbs?

cday
XnThusiast
Posts: 2455
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Illustrator thumbs don't work anymore

Post by cday » Wed Jul 29, 2020 8:24 pm

AndreaK wrote:
Wed Jul 29, 2020 8:08 pm
Hi, no I don't. Is it necessary to download it in order to view the AI thumbs?
As the Wiki link says, Ghostscript is necessary to view AI images, so I presume also thumbs...

There may be another issue after you have confirmed that you can view full AI images, concerned with the setting required to determine which thumbs are displayed by default in the browser, I can't help you with that... :(

User avatar
AndreaK
Posts: 4
Joined: Wed Jul 29, 2020 7:34 pm

Re: Illustrator thumbs don't work anymore

Post by AndreaK » Thu Jul 30, 2020 4:54 pm

Thanks. I think I will use XnView for Affinity files, and when it comes to AI files -- I will stick with Bridge.

cday
XnThusiast
Posts: 2455
Joined: Sun Apr 29, 2012 9:45 am
Location: Cheltenham, U.K.

Re: Illustrator thumbs don't work anymore

Post by cday » Thu Jul 30, 2020 5:18 pm

AndreaK wrote:
Thu Jul 30, 2020 4:54 pm
Thanks. I think I will use XnView for Affinity files, and when it comes to AI files -- I will stick with Bridge.
The setting I referred to above now I've found it is:

Tools > Settings > Browser > File list -- Custom filter

With Ghostscript installed according to the wiki instructions, for AI/PS/PDF files both images and thumbnails should be displayed with the default settings.

Post Reply