Some gifs changes their background when zoomed in/out

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
zencd
Posts: 29
Joined: Wed Jul 05, 2006 7:06 pm
Location: Saint-Petersburg, Russia

Some gifs changes their background when zoomed in/out

Post by zencd » Wed Mar 14, 2007 4:35 pm

Synopsys: some gifs changes their background when zoomed in/out

Reproduction:

1) Open this GIF in xnview 1.90.2 windows xp p2: http://i18.tinypic.com/34ezy9f.gif (it's 100% of size at my PC)

2) It has unexpected black background (while the background is true "white" in windows std viewer)

3) zoom out (eg 70%) -- the background gets white

4) zoom to 100% or more -- it get black again

User avatar
xnview
Author of XnView
Posts: 33640
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Some gifs changes their background when zoomed in/out

Post by xnview » Wed Mar 14, 2007 4:48 pm

zencd wrote:Synopsys: some gifs changes their background when zoomed in/out

Reproduction:

1) Open this GIF in xnview 1.90.2 windows xp p2: http://i18.tinypic.com/34ezy9f.gif (it's 100% of size at my PC)

2) It has unexpected black background (while the background is true "white" in windows std viewer)

3) zoom out (eg 70%) -- the background gets white

4) zoom to 100% or more -- it get black again
Try the 1.90.3
Pierre.

User avatar
zencd
Posts: 29
Joined: Wed Jul 05, 2006 7:06 pm
Location: Saint-Petersburg, Russia

Post by zencd » Wed Mar 14, 2007 4:51 pm

the same result with 1.90.3

btw, 1.90.2 didn't found that update ;-)

User avatar
XnTriq
Moderator & Librarian
Posts: 5600
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Wed Mar 14, 2007 10:05 pm

This seems to be related to the preference settings in View » View » Auto Image Size.
If the image isn't “shrunk” upon opening (No fit or Fit window to image) everything works just fine.

User avatar
XnTriq
Moderator & Librarian
Posts: 5600
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Tue May 22, 2007 8:15 pm

Fixed in v1.91!

User avatar
zencd
Posts: 29
Joined: Wed Jul 05, 2006 7:06 pm
Location: Saint-Petersburg, Russia

Post by zencd » Tue May 22, 2007 8:24 pm

not fixed for me, the things get even worse a bit with 1.91

1) just opened picture has the same unexpected black background as it was before

2) pressing zooming out, background stays the same black (new behaviour)

User avatar
XnTriq
Moderator & Librarian
Posts: 5600
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Tue May 22, 2007 9:15 pm

Hello zencd,

would you please tell us what your settings are for Auto Image Size and High quality zoom (both options are located in Tools » Options... » View » View).
xnview ([url=http://newsgroup.xnview.com/viewtopic.php?t=12641]XnView 1.91[/url]) wrote:Fixed:

[...]

* Display problem with trasnparent (index) picture and high zoom quality - - http://newsgroup.xnview.com/viewtopic.php?t=12215

User avatar
zencd
Posts: 29
Joined: Wed Jul 05, 2006 7:06 pm
Location: Saint-Petersburg, Russia

Post by zencd » Tue May 22, 2007 9:25 pm

Image

"Auto Image Size" == fit to desktop, large only
cannot locate "High quality zoom"

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Fine here

Post by Clo » Tue May 22, 2007 9:27 pm

—> zencd

:) Hello !

• I tested your sample at this moment in 1.91, it's displayed OK !

- I can zoom in - out - restore 1:1 scale - fit to window, the transparency remains perfectly,
I have always the BG colour of my “View” window…

• Same in the browser, as well as the thumb nail as for the preview, I can change the preview size at will, all is right…
- “High quality” is totally disabled here.
- “Use Transparency Index” is enabled.

:mrgreen: KR
Claude
Clo
Last edited by Clo on Tue May 22, 2007 11:11 pm, edited 1 time in total.
Old user ON SELECTIVE STRIKE till further notice

User avatar
zencd
Posts: 29
Joined: Wed Jul 05, 2006 7:06 pm
Location: Saint-Petersburg, Russia

Post by zencd » Tue May 22, 2007 9:31 pm

okay; it's a very rare case anyway

User avatar
XnTriq
Moderator & Librarian
Posts: 5600
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Post by XnTriq » Tue May 22, 2007 9:50 pm

zencd wrote:cannot locate "High quality zoom"
You can see it on your screenshot. It's the field with the two checkboxes (“Reduce”/“Enlarge”).

I was able to reproduce this with Version 1.90.3, but no matter what I try, in v1.91 the bug doesn't occur anymore. :?

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh » Tue May 22, 2007 10:03 pm

zencd wrote:not fixed for me, the things get even worse a bit with 1.91

1) just opened picture has the same unexpected black background as it was before

2) pressing zooming out, background stays the same black (new behaviour)
The problem is fixed for me also- the following option is needed for sample:
Options... View>[x]Use transparent index (<=8 bits) or alpha channel
Hmm... you show that in picture.
Last edited by marsh on Tue May 22, 2007 10:51 pm, edited 2 times in total.

User avatar
zencd
Posts: 29
Joined: Wed Jul 05, 2006 7:06 pm
Location: Saint-Petersburg, Russia

Post by zencd » Tue May 22, 2007 10:07 pm

yes, the bug has gone when I unchecked that "strange" checkbox ("Use transparent index...") :)

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

Post by Drahken » Wed Jun 06, 2007 11:57 pm

I can't reproduce this bug on 1.91, the background always remains white.
Are you certain your upgrade was successful? Have you checked info->about to make sure it says 1.91? Have you tried reinstalling 1.91 to a new folder, make sure you're not getting some sort of holdover bug from some old files?

Post Reply