little problem installing ShellExtension x64 1.6

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Indyaner
Posts: 3
Joined: Fri Nov 16, 2007 12:06 pm
Contact:

Post by Indyaner » Fri Nov 16, 2007 9:51 pm

Same Problem here:

WinXP x64 Prof. SP2

Damnit!
I used Picaview for Years. but it doestn work unter x64. Same like FirmTools ShellExtension 2. And now XnView ... and this was at least signed for 64bit... ARRR!!!

bye

User avatar
xnview
Author of XnView
Posts: 31891
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Sat Nov 17, 2007 9:42 am

Indyaner wrote:Same Problem here:

WinXP x64 Prof. SP2

Damnit!
I used Picaview for Years. but it doestn work unter x64. Same like FirmTools ShellExtension 2. And now XnView ... and this was at least signed for 64bit... ARRR!!!
Even if you register it with regsrv32?
Pierre.

Indyaner
Posts: 3
Joined: Fri Nov 16, 2007 12:06 pm
Contact:

Post by Indyaner » Sat Nov 17, 2007 12:55 pm

I try to resvr32 it manually via cmd like henry_jones told it in the first post, but everytime i try this way I get an Error-Message:

German
Image

English
Image



I try it in both way: Program Files (x86) & Program Files

Any Ideas?


For later on if someone got the same errors I will now type the errormessage to find this post via a searchengine:

LoadLibrary("C:\Program Files (x86)\XnView\ShellEx\XnViewShellExt.dll") fehlgeschlagen - Diese Anwendung konnte nicht gestartet werden, weil die Anwendungskonfiguration nicht ordnungsgemäß ist. Zur Problembehebung sollten sie die Anwendung neu installieren.

LoadLibrary("C:\Program Files (x86)\XnView\ShellEx\XnViewShellExt.dll") failed - This application has failed to start because the application configuration is incorrect. Reinstall this application may fix this problem.

Guest

Re: found a fix ! i guess...

Post by Guest » Wed Nov 21, 2007 7:33 am

Anonymous wrote:Ok,

I had exactly the same problem (Windows vista Business 64 bit French).

Did not manage to make the executable work, same message as yours saying it's not a valid win32 file (no wonder since i'm installing the 64 bit version, i wonder why it expects a 32 bit file anyways ! )
By the way, why does it want to install it by default in "program files (x86)" when it's a 64 bit dll ? Is there a probleme in the detection of 32/64 bit ?

Tried to register the dll manually with (%windir%\system32\regsvr32 "..path to the file"), which is the correct regsvr32 to register a 64 bit dll as far as i know, the one in syswow64 being for 32 bit dlls (i know, the names are incredibly misleading, if i'm wrong please tell me) and got an error message.
Something about "sidebyside" and a missing file Microsoft.VC80.ATL

Looked around a little and found a link to "Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)" you can dowlaod here : http://www.microsoft.com/downloads/deta ... layLang=en

With this package installed i tried to register the dll again, and this time it worked ! Hurray !

But.... I still don't have the thumbnails of the images in windows explorer ! (PSD files)
I only have a thumbnail of the file in the contextual menu that appears when i right click on it. Not directly in the thumbnail view in explorer !

Is this normal ? Or is the dll not installed properly ?

How can i see the thumnails of my files directly in explorer ?

Merci pour toute aide
Installing the C++ SP as mentioned above and then manually running regsvr32 worked for me

Guest

Post by Guest » Wed Nov 21, 2007 6:23 pm

my way to install the shell extension in vista 64:

1 install xnview with extension
2 create link with: %systemroot%\syswow64\regsvr32 "c:\program files (x86)\xnview\XnViewShellExt.dll"
3 right click on the link and use "run as administrator" (may be it's "launch as administrator", my french version of vista doesn't make any difference ;) )
4 right click on xnview link and use "run as administrator" (or "launch..." etc)
5 set up shell options

I didn't need to install the "Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)" because it still was.

that's all

Indyaner
Posts: 3
Joined: Fri Nov 16, 2007 12:06 pm
Contact:

Post by Indyaner » Sat Nov 24, 2007 10:21 am

Mhhh... i still got this Error-Message. I think in my case its a much larger problem at registering the reg itself then the way how to register. Any Ideads?

Henry_Jones
Posts: 20
Joined: Sat Mar 17, 2007 10:18 am

Post by Henry_Jones » Mon Nov 26, 2007 8:53 pm

With Version 1.70 it seems now neccessary to install the Microsoft C++ Runtime update. In 1.60 I could do without.

In 1.70 there is now an error stating something about side to side configuration. Here in german:

Cannot include img Tags, wtf ?
Here als Link: Image

This is gone after installing the runtime update, but you still have to register it yourself.

User avatar
xnview
Author of XnView
Posts: 31891
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Nov 27, 2007 7:06 am

Henry_Jones wrote:With Version 1.70 it seems now neccessary to install the Microsoft C++ Runtime update. In 1.60 I could do without.
The 32bit version?
Pierre.

Henry_Jones
Posts: 20
Joined: Sat Mar 17, 2007 10:18 am

Post by Henry_Jones » Tue Nov 27, 2007 7:25 am

@xnview: no the 64 Bit Version. The 32 Bit was not tested yet, but I guess having installed VS 2005 on the 32 Bit Laptop makes the runtime install obsolete.

When I find time to create my prefered resolutions I'll change to 1.70 there too.

User avatar
xnview
Author of XnView
Posts: 31891
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Tue Nov 27, 2007 7:51 am

Henry_Jones wrote:@xnview: no the 64 Bit Version. The 32 Bit was not tested yet, but I guess having installed VS 2005 on the 32 Bit Laptop makes the runtime install obsolete.
The 64bits version is built with VS2005, not the 32bits version
Pierre.

Henry_Jones
Posts: 20
Joined: Sat Mar 17, 2007 10:18 am

Post by Henry_Jones » Tue Nov 27, 2007 3:32 pm

No problems with the 32 Bit Version, but seems to be still 1.6.1 (downloaded the zip version)

Is there a chance that the features from here http://newsgroup.xnview.com/viewtopic.php?t=12655 get integrated ?

At the moment (having made the preview size "configurable" myself) point 2 - copying the image to the clipboard would be my favored wish ;)

I have to use an old application that only accepts bmp files or image data pasted from the clipboard.

vista_x64_user

Re: found a fix ! i guess...

Post by vista_x64_user » Sun Dec 09, 2007 1:03 pm

Anonymous wrote: Looked around a little and found a link to "Microsoft Visual C++ 2005 SP1 Redistributable Package (x64)" you can dowlaod here : http://www.microsoft.com/downloads/deta ... layLang=en

With this package installed i tried to register the dll again, and this time it worked ! Hurray !
Thanks man! That's it!

Post Reply