Xnview producing invalid file header? Exif info

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
heraldo
Posts: 7
Joined: Wed Mar 08, 2006 12:39 pm

Xnview producing invalid file header? Exif info

Post by heraldo » Fri Nov 19, 2010 12:35 pm

Posted this on Irfanview forums, but it turns out that this might be a bug in XnView:
http://en.irfanview-forum.de/vb/showthr ... #post32752

To produce the issue I save a file in Photoshop CS5 then run a batch processing in XnView. Example of a file not showing Exif info in other image viewers after being saved in XnView:
http://en.irfanview-forum.de/vb/attachm ... 1289985739

User avatar
xnview
Author of XnView
Posts: 32704
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Xnview producing invalid file header? Exif info

Post by xnview » Fri Nov 19, 2010 2:27 pm

Which version do you use?
Could you send me the original file?
Pierre.

heraldo
Posts: 7
Joined: Wed Mar 08, 2006 12:39 pm

Re: Xnview producing invalid file header? Exif info

Post by heraldo » Sat Nov 20, 2010 6:15 pm

I'm using version 1.97.8, resizing the images I get out of Photoshop CS5 in XnView produce the issue, here is one such file: http://gandhi2.fastmail.fm/01.JPG

User avatar
xnview
Author of XnView
Posts: 32704
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Xnview producing invalid file header? Exif info

Post by xnview » Mon Nov 22, 2010 7:53 pm

Ok, it's not a bug. Old software doesn't support that XMP block comes before EXIF block.
To be compatible with them, i'll change the order...
Pierre.

User avatar
xnview
Author of XnView
Posts: 32704
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Xnview producing invalid file header? Exif info

Post by xnview » Thu Mar 03, 2011 9:55 am

Pierre.

Post Reply