RC4: non-painting rectangular area

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: helmut, XnTriq, xnview

scratch
Posts: 82
Joined: Sun May 22, 2005 11:23 pm
Location: USA

RC4: non-painting rectangular area

Post by scratch »

intermittently i'm seeing a rectangular area that doesn't paint in the lower-left corner on only medium-sized images (around 400x400). this never happens with larger images or smaller images. it seems to happen more often than not when i have a lot of programs open, so maybe a memory or resources issue? but considering all other programs work just fine as do large and small images in XnView, it seems like it should be fixable. i can provide screenshots if necessary. in case it's important, first time i ever saw this occur was with RC3.

XnView 1.80 <x>
User avatar
xnview
Author of XnView
Posts: 38351
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: RC4: non-painting rectangular area

Post by xnview »

scratch wrote:intermittently i'm seeing a rectangular area that doesn't paint in the lower-left corner on only medium-sized images (around 400x400). this never happens with larger images or smaller images. it seems to happen more often than not when i have a lot of programs open, so maybe a memory or resources issue? but considering all other programs work just fine as do large and small images in XnView, it seems like it should be fixable. i can provide screenshots if necessary. in case it's important, first time i ever saw this occur was with RC3.
Yes, please send me screenshots.
Pierre.
scratch
Posts: 82
Joined: Sun May 22, 2005 11:23 pm
Location: USA

Post by scratch »

i will take some next time it occurs and post them here (most likely later today).
scratch
Posts: 82
Joined: Sun May 22, 2005 11:23 pm
Location: USA

Post by scratch »

here's a screenshot. as you can see, this area still shows the explorer window it popped up on top of. were i to cycle to the next image, it would show part of this image there.

Image
User avatar
xnview
Author of XnView
Posts: 38351
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

scratch wrote:here's a screenshot. as you can see, this area still shows the explorer window it popped up on top of. were i to cycle to the next image, it would show part of this image there.
But how to reproduce it?
Someone with same problem?
Pierre.
scratch
Posts: 82
Joined: Sun May 22, 2005 11:23 pm
Location: USA

Post by scratch »

like i said, it happens when i open lots of programs (but not to the point that anything else stops working). maybe when a large percentage of xnview is running in virtual memory instead of physical memory?