RC5: Inconsistent behaviors into and out of FS mode

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: helmut, XnTriq, xnview

kaptainkory
Posts: 41
Joined: Mon May 23, 2005 4:59 am

RC5: Inconsistent behaviors into and out of FS mode

Post by kaptainkory »

This may just be MY problem, but let me try to explain some inconsistent behaviors I'm experiencing when switching into and out of Fullscreen Mode...

Right-click thumbnail -> "View in Fullscreen"
Esc = closes image, returns to browser (as expected)
Double left-click = closes image, returns to browser
F11 = closes image, returns to browser
Mouse wheel click = closes image, returns to browser
Right-click = no option to exit FS Mode, no option to close image, etc.
Enter = does nothing?

Now try this...

Right-click thumbnail -> "Open"
Esc = closes image, returns to browser (as expected)
Double left-click = into and out of FS Mode
F11 = into and out of FS Mode
Mouse wheel click = into and out of FS Mode
Right-click = option to enter FS Mode, no option to close image, etc.
Enter = leaves image open, returns to browser

So now my question is, why are the behaviors so different? For example, if I have an image open in FS Mode, shouldn't F11 do the same thing, regardless of the path I took to get the image open in FS Mode to begin with?

Sorry for the long explanation. I hope it makes sense and has not been discussed elsewhere.

Thanks,
Kory

XnView 1.80 <x>
Dreamer
XnThusiast
Posts: 4608
Joined: Sun Jul 25, 2004 9:08 pm

Post by Dreamer »

Enter (if is set to "switch between browser and viewer") should always go from both fullscreen modes to the browser I think.

Please check this - Options>General>Switch mode

There is one (known) bug with "Browser, Fullscreen and Viewer" option.
kaptainkory
Posts: 41
Joined: Mon May 23, 2005 4:59 am

Post by kaptainkory »

Hmm, doesn't look like. I think I have all of those settings on their defaults, too. But this brings up another question... If I am in browser mode and press enter, this OPENS the selected image as expected. When I press enter again, this SWITCHES back to browser as expected. Then when I press enter yet again, this OPENS a new instance of the image...it does not SWITCH back to the image I originally opened. Is this the correct behavior?
User avatar
xnview
Author of XnView
Posts: 37753
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: RC5: Inconsistent behaviors into and out of FS mode

Post by xnview »

kaptainkory wrote:This may just be MY problem, but let me try to explain some inconsistent behaviors I'm experiencing when switching into and out of Fullscreen Mode...

Right-click thumbnail -> "View in Fullscreen"
Esc = closes image, returns to browser (as expected)
Double left-click = closes image, returns to browser
F11 = closes image, returns to browser
Mouse wheel click = closes image, returns to browser
Right-click = no option to exit FS Mode, no option to close image, etc.
Enter = does nothing?

Now try this...

Right-click thumbnail -> "Open"
Esc = closes image, returns to browser (as expected)
Double left-click = into and out of FS Mode
F11 = into and out of FS Mode
Mouse wheel click = into and out of FS Mode
Right-click = option to enter FS Mode, no option to close image, etc.
Enter = leaves image open, returns to browser

So now my question is, why are the behaviors so different? For example, if I have an image open in FS Mode, shouldn't F11 do the same thing, regardless of the path I took to get the image open in FS Mode to begin with?
By default, when you are in FS, you returns to the mode that you had before.
Pierre.
User avatar
xnview
Author of XnView
Posts: 37753
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

kaptainkory wrote:Hmm, doesn't look like. I think I have all of those settings on their defaults, too. But this brings up another question... If I am in browser mode and press enter, this OPENS the selected image as expected. When I press enter again, this SWITCHES back to browser as expected. Then when I press enter yet again, this OPENS a new instance of the image...it does not SWITCH back to the image I originally opened. Is this the correct behavior?
Perhaps an enhancement for 1.81
Pierre.