REQ: Don't use first frame for thumbnails

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

REQ: Don't use first frame for thumbnails

Post by Dreamer »

Reason: :(

Image
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: REQ: Don't use first frame for thumbnails

Post by xnview »

Dreamer wrote:Reason: :(
Yes, i understand ;-)
Pierre.
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

Not fixed in RC6.

I still have 5 black screens (of 9 above).

Pierre, what frame do you use?

Moved back to "New/Open".
ckit
XnThusiast
Posts: 2446
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit »

Yes, it's still not fixed in RC6.
I think XnView is still using the first frame cause if you switch off "Show first frame of AVI/MPG" you get no thumbnail at all.
XnViewMP 64bits and Windows 10 Pro x64 2004
PhotoFiltre Studio X
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview »

ckit wrote:Yes, it's still not fixed in RC6.
I think XnView is still using the first frame cause if you switch off "Show first frame of AVI/MPG" you get no thumbnail at all.
No, i use frame after 2 seconds
Pierre.
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

xnview wrote:No, i use frame after 2 seconds
Are you sure? Not the 2nd frame?
Olive
Posts: 215
Joined: Wed Oct 06, 2004 9:18 pm
Location: Marseille
Contact:

Post by Olive »

xnview wrote:I use frame after 2 seconds
I confirm this is OK with short videos, but "real" movies' first 2 seconds often consist of black frames. I admit it's not easy to get it look good with every movie.
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

Olive wrote:
xnview wrote:I use frame after 2 seconds
I confirm this is OK with short videos, but "real" movies' first 2 seconds often consist of black frames. I admit it's not easy to get it look good with every movie.
I see that frame after 2 seconds is used probably, but I'm not sure if it is used for all movies - my movies are short trailers and I still have 5 black screen thumnbails. Maybe some videos doesn't accept that setting...

Pierre, could you use frame after 5 seconds, or maybe 100th frame?
User avatar
xnview
Author of XnView
Posts: 34093
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview »

Dreamer wrote:
Olive wrote:
xnview wrote:I use frame after 2 seconds
I confirm this is OK with short videos, but "real" movies' first 2 seconds often consist of black frames. I admit it's not easy to get it look good with every movie.
I see that frame after 2 seconds is used probably, but I'm not sure if it is used for all movies - my movies are short trailers and I still have 5 black screen thumnbails. Maybe some videos doesn't accept that setting...

Pierre, could you use frame after 5 seconds, or maybe 100th frame?
Yes, i can use frame after 5 seconds, (and remember clear your cache)
Pierre.
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

xnview wrote:
Dreamer wrote:...Pierre, could you use frame after 5 seconds, or maybe 100th frame?
Yes, i can use frame after 5 seconds, (and remember clear your cache)
Thanks (cache is not the problem).

Could you send me a test version, I think there could be another problem with some movies...
...I'm not sure if it is used for all movies - my movies are short trailers and I still have 5 black screen thumnbails. Maybe some videos doesn't accept that setting...
ckit
XnThusiast
Posts: 2446
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit »

You really need to use the frame after 30-60 seconds at least.
If at all possible make an option for it so everyone can configure it to what they like (in seconds of course)
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Post by Olivier_G »

If you can easily get the total duration of the movie (in frames or whatever), you could choose the frame right in the middle of the movie...
-> You will get a meaningful picture (99.9% of the time)
Edit: even better for performance -> choose the first keyframe after that middle.

Note about adding more and more options: it is probably something that should be avoided in XnView. There are already a lot (too many) options that clutter the panel, and make it difficult to understand.
- A long time user will not be bothered by this and will be happy
- A newcomer will have to read the help-file +ask questions in the forum, BEFORE even being able to set XnView the way he likes.

Just to illustrate this: the first time I tried XnView, I wasn't happy with the default setting. I went to the Options panel... and coughed. I tried to change some options by guessing, and didn't get what I expected. A lot of people will stop there and discard XnView...
I even think that we should start a new thread (for XnView 1.81), just to reduce/optimize those options...

Olivier
Last edited by Olivier_G on Tue Jun 14, 2005 9:41 am, edited 1 time in total.
ckit
XnThusiast
Posts: 2446
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit »

I strongly disagree, the more you can customize in XnView the better it will be.
I feed on tweaking my OS and software :)

How about a Default mode and Advanced mode like Spybot?
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Post by Olivier_G »

ckit wrote:How about a Default mode and Advanced mode like Spybot?
You mean... to add another option? :mrgreen:

Maybe we should wait the release of 1.80 finale before discussing this issue, in order to let the forum slow down a bit... :D
And we should probably avoid discussing it further in this thread, in order to stay in topic.

Olivier
PS: I aknowledge that my note was Out Topic. I will delete it if required/needed.
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer »

ckit wrote:You really need to use the frame after 30-60 seconds at least.
I disagree, many users have 10-30 seconds movies from digital camera, cell phone...

The best solution would be frame after 10% of the time - for 10 seconds movies and for 100 minutes movies - if possible - no option is needed here.

If it's not possible (10%) I suggest "frame after 5 or 10 seconds", what you think?
Post Reply