Video thumbnails for WMV files

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Video thumbnails for WMV files

Post by ckv » Sat Aug 03, 2013 1:31 pm

On both XnView 2.04 and XnViewMP 0.61 all of my WMV video file thumbnails only show half of the frame (see pictures below).

I noticed this after I rebuild my rather old thumbnail cache on XnView, so I don't know how long it's been this way, but I will try out some of the older versions to see if they are any better.

I'm using up-to-date Windows 7 and I don't have any external codecs installed at the moment.

XnView:
Image

XnViewMP:
Image
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
xnview
Author of XnView
Posts: 31738
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Video thumbnails for WMV files

Post by xnview » Sun Aug 04, 2013 11:06 am

could you send me a sample?
Pierre.

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: Video thumbnails for WMV files

Post by ckv » Wed Aug 07, 2013 7:00 pm

xnview wrote:could you send me a sample?
Ok, I sent a sample file.

---
I did some more testing and I was able to reproduce the problem on Windows XP. On Windows XP it was actually worse and all the WMV file thumbnails are completely blank. I also tried older versions of XnView and it was the same on all the versions (1.98.1, 1.98.8, 1.99 and 2.04) I tried.

Interestingly the problem does not affect the "Video thumbnail gallery..." tool, but the "Extract movie frames" tool has a different kind of problem with WMV files where it would always extract the same frame (the first frame of the video I believe) over and over no matter what options you choose. Other video formats seem to work just fine.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

User avatar
xnview
Author of XnView
Posts: 31738
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Video thumbnails for WMV files

Post by xnview » Thu Aug 08, 2013 11:58 am

I can reproduce...
Pierre.

Jean_59
Posts: 25
Joined: Wed Dec 31, 2008 11:02 am
Location: France, Nord

Re: Video thumbnails for WMV files

Post by Jean_59 » Sat Aug 10, 2013 3:56 pm

I have the same problem (Windows 7/64 bits); It looks like it only occurs with .WMV files, not MPG or AVI or mov.
The trouble appeared not very long ago, roughly simultaneously with XnView and MP, independently of the "Ui-less" setting "VideoframePercent".
Some thumbnails have 2 black sripes, some one, and some are all black.
I changed a .AVI file (thumbnail OK)into a .WMV with XmediaRecode and FormatFactory: both new files are affected (Xnview2.04 and MP0.61)
I can confirm version 1.996 has the problem.
Win 10-64, Intel i7, idsplay Dell U2413

Jean_59
Posts: 25
Joined: Wed Dec 31, 2008 11:02 am
Location: France, Nord

Re: Video thumbnails for WMV files

Post by Jean_59 » Fri Aug 16, 2013 6:44 am

No more problems !!

This morning, after a reboot (Windows update) the thumbnails are OK (just click Display/rebuild thumbnails for old files)
Xnview MP is also OK.
Apparently the trouible had nothing to do with XnView !
Win 10-64, Intel i7, idsplay Dell U2413

User avatar
ckv
Posts: 779
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Re: Video thumbnails for WMV files

Post by ckv » Fri Aug 30, 2013 11:44 am

Jean_59 wrote:No more problems !!

This morning, after a reboot (Windows update) the thumbnails are OK (just click Display/rebuild thumbnails for old files)
Xnview MP is also OK.
Apparently the trouible had nothing to do with XnView !
Indeed the thumbnails are fine now. The only patch to fix this, that I can think, is the patch for MS13-057. However it is a security update not a bug fix, so something is not right here.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

Post Reply