Incorrect number of arguments passed to external programs

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
drew
Posts: 1
Joined: Sat Apr 19, 2014 8:45 pm

Incorrect number of arguments passed to external programs

Post by drew » Sat Apr 19, 2014 9:31 pm

This may be by design but it seems that the Tools>Open With and Options->Interface->Toolbar->Buttons commands have a different behavior with respect to the number of files passed to the external program:

If an Open With program is run ...
And one or more folders are selected -> The program isn't executed
One or more files are selected -> The program is executed normally with each file passed as an argument (correctly)
One or more files and folders are selected -> The program is executed with each file passed as an argument and the folders are ignored.

If the same program is run from the toolbar ...
And one or more folders are selected -> The program is executed and only the first selected folder is passed to the external program
One or more files are selected -> The program is executed and only the first selected file is passed to the external program

The vbscript below (can't attach a vbs file) file shows the behavior if called from the open with and toolbar methods.

dim argc,argv
set argv = WScript.Arguments
argc = argv.count
if argc > 0 then
msgbox "Argc = " & argc
for i = 1 to argc
msgbox "Argv # " & i & " = " & argv(i-1)
next
else
msgbox "no arguments"
end if
BTW thanks for maintaining this great program and keeping an active forum. The sheer number of users and their varied applications seem to insure that every feature of the program gets explored and tested.

Drew

Post Reply