Transparency at zoom levels greater than 100%

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
omniplex
Posts: 127
Joined: Thu Feb 10, 2011 1:52 pm
Location: Hamburg
Contact:

Transparency at zoom levels greater than 100%

Post by omniplex » Sun Sep 21, 2014 3:45 pm

Apparently XnView 2.22 and some earlier versions cannot handle transparency at zoom levels > 100%. This could be a new bug or feature, or I haven't found the settings to fix it, or it never worked, but I didn't see it, because I only recently looked at pictures with semi-transparent (0 < alpha < 255) RGBA pixels. Background, my default view is "fit to window size", and for small pictures this is greater than 100%.

Presumably unrelated, or not, the grid view at 5x5 can be rather messy. At, say, 20x20, it gets better, but the rows go from A1 to A19 and continue with A1:, A1;, etc., i.e., row numbers 20 etc. don't work. IMO there should be no row and column headers at all in the grid. What I really need is a zoom level and a 1x1 grid to identify erroneous pixels. At the moment it is faster to use MSpaint.exe (F4) and its max. zoom (800%) instead of XnView (also at 800%) to get a decent 1x1 grid.

User avatar
XnTriq
Moderator & Librarian
Posts: 5355
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: Transparency at zoom levels greater than 100%

Post by XnTriq » Mon Sep 22, 2014 1:15 am

omniplex wrote:Apparently XnView 2.22 and some earlier versions cannot handle transparency at zoom levels > 100%.
Confirmed if High quality zoom for Enlarge (Tools » Options... » View » View) is activated.

Post Reply