BUG: XnView browser always auto selects first item...

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

BUG: XnView browser always auto selects first item...

Postby ghost zero » Thu Oct 09, 2014 3:54 pm

BUG: When switching to another program then back to XnView, the XnView browser always auto selects first item--even if nothing was originally selected. Can this be fixed?

XnView 2.24
Windows 7 x64

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

Re: BUG: XnView browser always auto selects first item...

Postby ghost zero » Tue Apr 21, 2015 3:28 pm

any fix for this yet?

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

Re: BUG: XnView browser always auto selects first item...

Postby ghost zero » Tue Dec 01, 2015 4:54 pm

please fix

User avatar
omniplex
Posts: 123
Joined: Thu Feb 10, 2011 1:52 pm
Location: Hamburg
Contact:

Re: BUG: XnView browser always auto selects first item...

Postby omniplex » Wed Dec 30, 2015 12:33 pm

ghost zero wrote:When switching to another program then back to XnView, the XnView browser always auto selects first item--even if nothing was originally selected.
I can't reproduce this with 2.34, presumably because I just don't get what doesn't work for you.

When I open XnView and two pictures (browser + red + remastered Lena, focus on red), and go to Chrome, then back to XnView, I arrive exactly where I left off. When I close both Lenas, XnView browser focus on Lena.tif (not the first in this folder), go to Chrome, back to XnView, I arrive exactly where I left off. And when I go to another folder with pictures, selecting nothing (preview empty, and no highlighted thumb indicating a selection), to Chrome and back again, there is still nothing highlighted, and the preview window is still empty.

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

Re: BUG: XnView browser always auto selects first item...

Postby ghost zero » Wed Dec 30, 2015 5:43 pm

to reproduce the problem...

- in xnview browser, click empty space to clear any selection
- in taskbar, click on empty space to make xnview lose focus
- click on xnview taskbar button to refocus xnview
- now the first item gets auto selected

User avatar
omniplex
Posts: 123
Joined: Thu Feb 10, 2011 1:52 pm
Location: Hamburg
Contact:

Re: BUG: XnView browser always auto selects first item...

Postby omniplex » Sat Apr 02, 2016 6:11 am

ghost zero wrote:- now the first item gets auto selected
ACK, got it now (or rather weeks ago, but I just figured out how to find undead forum threads where I posted something.) This bug could be a feature, i.e., something always must have the focus, and without other clues "something" boils down to "first thing". :?:

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

Re: BUG: XnView browser always auto selects first item...

Postby ghost zero » Fri Apr 14, 2017 6:42 pm

still happening in 2.39, please fix

User avatar
xnview
Author of XnView
Posts: 27888
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: BUG: XnView browser always auto selects first item...

Postby xnview » Sat Apr 15, 2017 8:35 am

ghost zero wrote:still happening in 2.39, please fix

The system send focus to listview and select current item
Pierre.

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

Re: BUG: XnView browser always auto selects first item...

Postby ghost zero » Sat Apr 15, 2017 9:15 am

whenever it happens, i always manually deselect it, so it becomes tedious and annoying. so can you prevent it from happening?

User avatar
xnview
Author of XnView
Posts: 27888
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: BUG: XnView browser always auto selects first item...

Postby xnview » Sat Apr 15, 2017 9:27 am

ghost zero wrote:whenever it happens, i always manually deselect it, so it becomes tedious and annoying. so can you prevent it from happening?

i don't think
Pierre.

ghost zero
Posts: 339
Joined: Mon Feb 05, 2007 8:26 pm

Re: BUG: XnView browser always auto selects first item...

Postby ghost zero » Sat Apr 15, 2017 3:50 pm

i realize file managers always need to remember the last item in focus. but this focus can be kept invisible and it doesn't need to be highlighting the file. i use another file manager called xyplorer that can accomplish this, so i know it is possible. and not even windows explorer has this problem. can you try to fix this in xnview?

NOTE: xnview doesn't even have this problem at startup. this problem only happens when refocusing the window.


Return to “Classic - Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests