'Go to next when delete' and tabs misbehavior

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

'Go to next when delete' and tabs misbehavior

Post by marsh » Sat Aug 13, 2005 9:41 am

With multiple tabs open, 'go to next image when deleting current' sometimes does not work.
1. 5 tabs open- browser, 1.jpg, 2.jpg, 3.jpg, 4.jpg
2. Large directory of jpgs (9000)
3. [x] go to next image when deleting current.
4.a. Deleted 3.jpg and it will instead go to first file in list- 1.jpg, not 4.jpg.
4.b. [Alternate Step- Don't use 4.a.] Go to 3.jpg's tab. Navigate forward to 7.jpg and delete it, then everything works as expected. It advances to 8.jpg.

I saw this a couple times (I cannot recreate this now):
4.a.? [Deleted 3.jpg- I saw continuous high CPU usage. I had to stop Xnview with task manager.
Last edited by marsh on Tue Sep 06, 2005 4:54 am, edited 3 times in total.

User avatar
xnview
Author of XnView
Posts: 31609
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 'Go to next when delete' and tabs misbehavior

Post by xnview » Tue Aug 16, 2005 12:39 pm

marsh wrote:With multiple tabs open, 'go to next image when deleting current' sometimes does not work.
1. 5 tabs open- browser, 1.jpg, 2.jpg, 3.jpg, 4.jpg
2. Large directory of jpgs (9000)
3. [x] go to next image when deleting current.
4.a. Deleted 3.jpg and it will instead go to first file in list- 1.jpg, not 4.jpg.
4.b. [Alternate Step- Don't use 4.a.] Go to 3.jpg's tab. Navigate forward to 7.jpg and delete it, then everything works as expected. It advances to 8.jpg.
You can always reproduce the problem??
Pierre.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: 'Go to next when delete' and tabs misbehavior

Post by marsh » Wed Aug 17, 2005 12:58 am

xnview wrote:
marsh wrote:With multiple tabs open, 'go to next image when deleting current' sometimes does not work.
1. 5 tabs open- browser, 1.jpg, 2.jpg, 3.jpg, 4.jpg
2. Large directory of jpgs (9000)
3. [x] go to next image when deleting current.
4.a. Deleted 3.jpg and it will instead go to first file in list- 1.jpg, not 4.jpg.
4.b. [Alternate Step- Don't use 4.a.] Go to 3.jpg's tab. Navigate forward to 7.jpg and delete it, then everything works as expected. It advances to 8.jpg.
You can always reproduce the problem??
Yes. And with small number of jpgs.

User avatar
xnview
Author of XnView
Posts: 31609
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 'Go to next when delete' and tabs misbehavior

Post by xnview » Wed Aug 17, 2005 8:56 am

marsh wrote:
xnview wrote:
marsh wrote:With multiple tabs open, 'go to next image when deleting current' sometimes does not work.
1. 5 tabs open- browser, 1.jpg, 2.jpg, 3.jpg, 4.jpg
2. Large directory of jpgs (9000)
3. [x] go to next image when deleting current.
4.a. Deleted 3.jpg and it will instead go to first file in list- 1.jpg, not 4.jpg.
4.b. [Alternate Step- Don't use 4.a.] Go to 3.jpg's tab. Navigate forward to 7.jpg and delete it, then everything works as expected. It advances to 8.jpg.
You can always reproduce the problem??
Yes. And with small number of jpgs.
And if you have only 5 jpeg, and only one tab?
Pierre.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: 'Go to next when delete' and tabs misbehavior

Post by marsh » Wed Aug 17, 2005 9:05 am

xnview wrote: And if you have only 5 jpeg, and only one tab?
I'll check again. I am not certain.

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: 'Go to next when delete' and tabs misbehavior

Post by marsh » Wed Aug 17, 2005 9:19 am

xnview wrote: And if you have only 5 jpeg, and only one tab?
Yes, but you need to start a tab on middle file and not change it.
If you start on #3 and delete, it goes to #1.
If you start on #3, and go to another file then delete, then it behaves normally.
With 1 brower tab and 1 view tab open.
This happens also with tabs disabled and 'use only one view'.
It only happens in viewer, not browser's fullscreen.

User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Re: 'Go to next when delete' and tabs misbehavior

Post by loth » Sat Aug 27, 2005 10:34 am

marsh wrote:With multiple tabs open, 'go to next image when deleting current' sometimes does not work.
I saw this a couple times (I cannot recreate this now):
hi, i'm glad somebody else had this too, because its hard to describe. :->

i'm experiencing the same "feature" while deleting files in fullscreen mode.

i delete a file, then in the upper left of the screen the filename of the next file is shown, but the picture is not updating.
if i press page-down, the picture is updating.

i had only one tab. (and the browser tab)
loth

User avatar
loth
Posts: 173
Joined: Thu Aug 11, 2005 3:21 pm
Location: Kölle

Post by loth » Wed Sep 07, 2005 12:05 pm

this issue is still alive in v1.80.2.

in fullscreen-mode (with more than 3 pics in the folder you're viewing the picture)
press ALT-M to move the viewed file.
move the picture to a directory of your choice.

after moving the picture, xnview shows the latest picture, not the next, as declared in the options.
loth

Post Reply