Browser displays thumbnails of only first file type

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
v1nc3
Posts: 3
Joined: Wed Jun 03, 2015 12:47 pm

Browser displays thumbnails of only first file type

Post by v1nc3 » Wed Jun 03, 2015 1:08 pm

Whenever there is a mix of different graphic file types (ie png and jpg) in a directory, XnView in Browser mode will only display thumbnails of the first graphic type up to the second and will not display any other images. Also when clicking on the thumbnail of the first graphic and going through the images it will only display images of the first graphic file type. If you look at the mixed image directory in explorer and click on the second, third or whatever mixed graphic type XnView in Viewer mode has no trouble displaying all image types.

I'm using Windows 7 x64 Ultimate and the latest Xnview - 2.32

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browser displays thumbnails of only first file type

Post by xnview » Wed Jun 03, 2015 1:18 pm

strange, are you able to reproduce each time?
Pierre.

v1nc3
Posts: 3
Joined: Wed Jun 03, 2015 12:47 pm

Re: Browser displays thumbnails of only first file type

Post by v1nc3 » Wed Jun 03, 2015 3:16 pm

Yes I am; happens every time.

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browser displays thumbnails of only first file type

Post by xnview » Thu Jun 04, 2015 7:26 am

v1nc3 wrote:Yes I am; happens every time.
could you send me a folder and tell me the way to reproduce?
Pierre.

v1nc3
Posts: 3
Joined: Wed Jun 03, 2015 12:47 pm

Re: Browser displays thumbnails of only first file type

Post by v1nc3 » Thu Jun 04, 2015 5:06 pm

Because you said 'strange' I took it upon myself to investigate further. There were 20 files in this one directory, the first 2 images were JPEGs and the other 18 that would not display in Browse mode were PNGs. I started thinking maybe the files that would not display in Xnview Browse mode were perhaps corrupted. So I tried opening them in Photoshop and it wouldn't open the non-displaying files. I then tossed them into an online detect filetype web page and the PNG files that would not display were actually JPEG files!

So XnView Browse refused to display their thumbnails because their file type was wrong. Renamed the PNGs to JPGs and viola all images displayed in XnView. Problem solved!

Quick side question: is it possible for XnView in Browse mode to still either display an image even if it has the wrong file extension (auto detect regardless of file extension) or possibly show a blank image w/maybe a color or some indicator letting the user know that it's a misnamed image? Would help others that aren't aware of why it's not displaying an image so they can fix that.

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Browser displays thumbnails of only first file type

Post by xnview » Mon Jun 08, 2015 8:02 am

you have Options>Browser>File list>Misc>Recognize by extension
Pierre.

Post Reply