Unable to open image

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
thire
Posts: 118
Joined: Sat Jul 30, 2005 10:26 am
Contact:

Unable to open image

Post by thire » Fri Aug 26, 2005 11:26 pm

I open Win2000 browser, click right on an image and select "open with" and then I selected (of course :) ) XnView. The program was not started, but the task manager told me the xnview.exe was running. I was not able to start xnview by doubleclicking the shortcut on my desktop and going directly to the file and clicking it did not work either.
When I finish in the taskmanager the process and doubleclick the shortcut on my desktop, everything is fine.
Not very sure where I made a mistake, please let me know...
Thomas

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: unable to start

Post by xnview » Mon Aug 29, 2005 3:32 pm

thire wrote:I open Win2000 browser, click right on an image and select "open with" and then I selected (of course :) ) XnView. The program was not started, but the task manager told me the xnview.exe was running. I was not able to start xnview by doubleclicking the shortcut on my desktop and going directly to the file and clicking it did not work either.
When I finish in the taskmanager the process and doubleclick the shortcut on my desktop, everything is fine.
Not very sure where I made a mistake, please let me know...
There is a little bug in the setup (with association), perhaps it's the problem.
Pierre.

thire
Posts: 118
Joined: Sat Jul 30, 2005 10:26 am
Contact:

Post by thire » Mon Aug 29, 2005 3:35 pm

I have no "problem" with this "bug", I just wanted to help! :) Just do some errorreporting in order to improve this fantastic piece of software! :)
th

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Mon Aug 29, 2005 4:19 pm

thire wrote:I have no "problem" with this "bug", I just wanted to help! :) Just do some errorreporting in order to improve this fantastic piece of software! :)
th
This is a known bug. When associating files using "Open with" (what you describe above), you will encounter this problem. The right way to associate files with XnView is to use XnView#s option dialog: "Tools > Options", category "Associations".

Various people have encountered this problem, perhaps it's time to write up a short FAQ.

@Pierre:
Perhaps the way XnView interprets the options could be improved?

Andrej
Posts: 1
Joined: Thu Sep 08, 2005 11:16 am

Post by Andrej » Thu Sep 08, 2005 2:24 pm

This is a known bug. When associating files using "Open with" (what you describe above), you will encounter this problem. The right way to associate files with XnView is to use XnView#s option dialog: "Tools > Options", category "Associations".
"Open With" or double-clicking on a file with a proper extension doesn't start XnView(1.80.3) in Win2000 - but it does in WinXP. It doesn't matter how you associate the files.

This bug appears only in Win2000.

User avatar
xnview
Author of XnView
Posts: 31607
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Post by xnview » Thu Sep 08, 2005 3:12 pm

Andrej wrote:
This is a known bug. When associating files using "Open with" (what you describe above), you will encounter this problem. The right way to associate files with XnView is to use XnView#s option dialog: "Tools > Options", category "Associations".
"Open With" or double-clicking on a file with a proper extension doesn't start XnView(1.80.3) in Win2000 - but it does in WinXP. It doesn't matter how you associate the files.

This bug appears only in Win2000.
Strange i have not it on my win2000 :-(
Pierre.

ss02ss02
Posts: 3
Joined: Thu Aug 11, 2005 5:43 pm

Post by ss02ss02 » Fri Sep 09, 2005 4:26 pm

If you add the association in Windows Explorer as follows it does work, but most of the time XnView will not open "Full Screen".

In "Tools->Folder Options->File Types" for JPG/JPEG or whatever you want for the "Registered file types" click the advanged button en edit the "open" under "actions", "Application used to perform action:" should look like:
"C:\Program Files\XnView\xnview.exe" -full "%1"
This would be using the default install path, don't forget the quotes!

Now double clicking works in Explorer, but again most likely XnView will not open in a full screen! And yes the -full is needed, anything else like -fi/-fa/-all will get you in XnView slideshow mode :-) And not giving any option will make XnView hang :-(

JDH

Post Reply