0.83: Import and sort - only works for some video formats?

Older bugs which are supposed to be fixed in 0.84. *** Please try to reproduce your bug and confirm the bug fix. ***

Moderator: Dreamer

Post Reply
mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

0.83: Import and sort - only works for some video formats?

Post by mjbiggs » Tue Oct 11, 2016 10:53 am

Hello

I've being trying to use the 'Import and sort' feature to move and rename video files.
What I'd like to do is rename and sort into new subfolders by file modified date.
Tried on simple test folder with one layer of subfolders containing *.avi, *.mov, *.mpg, *.mts files.
Only the *.mov files were renamed and moved, others types were untouched.

If I repeat with the 'Other Files' checkbox ticked then all types are moved but it doesn't help with my sorting.

So, a few questions:
Is there any way around this?
Is it all to do with exif?
Will a newer update of XnviewMP allow the renaming and sorting I'm after?

Many thanks.

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Import and sort - only works for some video formats?

Post by xnview » Wed Oct 12, 2016 1:25 pm

See Issue 991 for details.
Pierre.

mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

Re: Import and sort - only works for some video formats?

Post by mjbiggs » Wed Oct 12, 2016 3:48 pm

Great. Thanks very much. Enjoying 0.83 so far. Looking forward to 0.84.

ziotean
Posts: 3
Joined: Tue Nov 01, 2016 6:22 am

Re: Import and sort - only works for some video formats?

Post by ziotean » Tue Nov 01, 2016 6:28 am

same to me.

At least let me know which types of files were imported and which not. before or after import. why not let me choose
Jugdement only by exif is not a good idea, I have many mobilephone screen shots have modify date but no exif.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Import and sort - only works for some video formats?

Post by helmut » Mon Dec 05, 2016 8:55 pm

This problem is supposed to be fixed in XnView MP 0.84 beta 1. Could you please try and confirm the bug fix, mjbiggs and ziotean?

mjbiggs
Posts: 8
Joined: Thu Mar 03, 2011 2:16 pm

Re: Import and sort - only works for some video formats?

Post by mjbiggs » Fri Dec 09, 2016 12:02 pm

Hello

*** update to original issue: 0000991 - Import&sort video files not copied - http://newsgroup.xnview.com/viewtopic.php?f=36&t=33907 ***

I've just tried a few simple tests using Import and sort... for Beta2. Now correctly copying and sorting my different video files, so many thanks for that.
There does seem to be a renaming bug though, where an incorrect extension is applied, as below.

source folder comprised 3 video files of different types (.mts, .avi, .mov) plus 1 subfolder with 2 more video files (.wmv, .mov)

(also did 1 further test with an additional duplicate video file to see if it flagged up the duplicate - detected fine; as before all tests on Windows 7 Pro laptop)

Import and sort... results as follows:

Destination Subfolder: yyyy
New filename: unchecked
result: all video files sorted correctly

Destination Subfolder: yyyy
New filename: yyyyMMdd_hhmmss.Ext
result: sorting good; renaming good except files given extension: .ExGMT Standard Time or .ExGMT Daylight Time

Destination Subfolder: yyyy-MM-dd
New filename: unchecked
result: all video files sorted correctly

Destination Subfolder: yyyy-MM-dd
New filename: yyyyMMdd_hhmmss.Ext
result: sorting good; renaming good except files given extension: .ExGMT Standard Time or .ExGMT Daylight Time

User avatar
xnview
Author of XnView
Posts: 31143
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 0.84 beta2 - Import&sort video files - renaming issue

Post by xnview » Tue Dec 13, 2016 7:50 pm

will be fixed in beta 3
Pierre.

User avatar
helmut
Posts: 8153
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: 0.83: Import and sort - only works for some video format

Post by helmut » Tue Feb 07, 2017 8:27 pm

This problem is supposed to be fixed in XnView MP 0.84 final. Could you please try and confirm the bug fix, mjbiggs?

Post Reply