TIFF files not showing but TIF no problem

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

calgon
Posts: 3
Joined: Thu Mar 01, 2018 1:32 pm

TIFF files not showing but TIF no problem

Post by calgon »

XnView 2.43 Classic set as default for all photos

Attached two files:
Tif File.tif – MD5: ce9bbc54c4700c649aa7a3957957ac56
Tiff File.tiff – MD5: ce9bbc54c4700c649aa7a3957957ac56
Both files are identical except for extension & name

When I double click either file in File Explorer:
The Tif File.tif opens & everything is correct and I get: Tif File.png
The Tiff File.tiff XnView opens but nothing is shown: Tiff File.png

If I go to file open both files open correctly.
If I drag and drop both files open correctly.

Same problem with all my TIFF files, files with extension TIF no problem.

Windows 10 x64: 1709.16299.248

What am I doing wrong or is this a bug?
You do not have the required permissions to view the files attached to this post.
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: TIFF files not showing but TIF no problem

Post by xnview »

if you put these 2 files in a folder, you can view them in XnView's browser?
Pierre.
calgon
Posts: 3
Joined: Thu Mar 01, 2018 1:32 pm

Re: TIFF files not showing but TIF no problem

Post by calgon »

xnview wrote:if you put these 2 files in a folder, you can view them in XnView's browser?
Confirm can see both files in a browser folder.

It is only when I double click a tiff file that nothing shows
User avatar
xnview
Author of XnView
Posts: 36431
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: TIFF files not showing but TIF no problem

Post by xnview »

so i think that there is a problem in registry with .tiff entry
Pierre.
calgon
Posts: 3
Joined: Thu Mar 01, 2018 1:32 pm

Re: TIFF files not showing but TIF no problem

Post by calgon »

Thanks for your suggestion.

Problem solved by doing the following:
Uninstalled XnView
Restarted
Ran Regedit and removed all instances of XnView
Restarted
Installed XnView
Ran XnView as Admin
XnView Options/Windows File Associations
Set Xnview as default App.

Now works perfectly so as you say it was a registry problem but have no idea what caused it.

Thanks, Nick :D