No WMV thumbnails

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: helmut, XnTriq, xnview

Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

No WMV thumbnails

Post by Danny »

I can playback all WMV files. Windows Explorer can create thumbnails, as well as ACDSee. Only XNView does not create any WMV thumbnails.

I have all WMV9 codecs installed. But XnView will only create thumbnails if at least Windows Media Player 9 is installed.

Is there anything you can do about this?

Cheers
Dan
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: No WMV thumbnails

Post by xnview »

Danny wrote:I can playback all WMV files. Windows Explorer can create thumbnails, as well as ACDSee. Only XNView does not create any WMV thumbnails.

I have all WMV9 codecs installed. But XnView will only create thumbnails if at least Windows Media Player 9 is installed.

Is there anything you can do about this?
Perhaps you could send me a sample, please?
Pierre.
Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Re: No WMV thumbnails

Post by Danny »

xnview wrote:
Danny wrote:I can playback all WMV files. Windows Explorer can create thumbnails, as well as ACDSee. Only XNView does not create any WMV thumbnails.

I have all WMV9 codecs installed. But XnView will only create thumbnails if at least Windows Media Player 9 is installed.

Is there anything you can do about this?
Perhaps you could send me a sample, please?
Sure, i will. But it doesn't matter which WMV video i use. None of them will work for thumbnails.

The strangest thing is that i can play them even with the internal player.
Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny »

I've successfully sent you a WMV. Anything yet?
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Danny wrote:I've successfully sent you a WMV. Anything yet?
Hum no, i think that you have not used the good email address ....@xnview.com??
Pierre.
Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny »

So, does it work on WinXP, too, or do you have the same problem there?
User avatar
xnview
Author of XnView
Posts: 37889
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

Danny wrote:So, does it work on WinXP, too, or do you have the same problem there?
Yes :-(
Pierre.
Guest

Post by Guest »

xnview wrote:
Danny wrote:So, does it work on WinXP, too, or do you have the same problem there?
Yes :-(
So no WMV thumbnails on WinXP unless you have at least WMP9 installed. That blows. :/
Danny
Posts: 564
Joined: Sat Sep 04, 2004 5:09 pm

Post by Danny »

I found out something. Recently i installed the latest version of media player classic. Since then it couldn't playback certain WMV videos anymore while the Windows Media Player still could.

Now there's this one option in MPC called "Use the WM ASF Reader for Windows Media Files", and once i deactivated that option the WMV videos could be played again.

So maybe you made the same "mistake" with XNView. Maybe you should compare your playback and thumbnailing routines more closely. I'm pretty sure you're doing things differently for both somewhere alongt the way.

Cheers
Danny