Configured Programs QT Error

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
User avatar
Akovia
Posts: 54
Joined: Sat Apr 02, 2011 2:10 am
Contact:

Configured Programs QT Error

Post by Akovia » Mon Nov 26, 2018 9:08 pm

Arch Linux

I'm getting errors when launching external programs that use qt, which happens to be all my external programs.

smplayer

Code: Select all

usr/bin/smplayer: /opt/xnviewmp/lib/libQt5Core.so.5: version `Qt_5.11' not found (required by /usr/bin/smplayer)
For gimp, it's actually some of the plugins that use qt.

Code: Select all

/usr/lib/gimp/2.0/plug-ins/gmic_gimp: /opt/xnviewmp/lib/libQt5Core.so.5: version `Qt_5.11' not found (required by /usr/lib/gimp/2.0/plug-ins/gmic_gimp)

I'm assuming this is an arch problem as it's always using the latest versions and it seems xnviewmp is still using qt version 5.9.5.

What I discovered while troubleshooting this is that if gimp was already open before opening an image from xnviewmp, I would have no troubles with the qt plugin crashing. Also, if I launch smplayer from a bash script that launches it from the console, it will work as well.

Code: Select all

#!/bin/bash 
xfce4-terminal --tab --drop-down -x smplayer --verbose "$@
I'm not sure how all the moving parts work, or if this is actually a bug or not, but wondered if there is a better way to handle it when there is a qt mismatch?

Cheers
Arch Linux
XnView MP

Post Reply