Missing tabs text in tabs and/or tabs

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

Missing tabs text in tabs and/or tabs

Post by dorcom » Mon Apr 20, 2020 8:18 pm

Since a few days xnview 2.49.2 shows only one tab and it is empty. There is no text in tabs or other tabs. (image attached)
I checked the settings but could not find a relevant one, even by trial & error.
Uninstalling xnview and reinstalling did not help to resolve the problem.
Anyone can help or know the issue?
Thanks in advance!
R
Attachments
Xnview 2.49.2 missing tabs & text.jpg
Xnview 2.49.2 missing tabs & text.jpg (19.01 KiB) Viewed 362 times

User avatar
xnview
Author of XnView
Posts: 33337
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Missing tabs text in tabs and/or tabs

Post by xnview » Tue Apr 21, 2020 8:30 am

strange, could you send me your xnview.ini?
Pierre.

dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

Re: Missing tabs text in tabs and/or tabs

Post by dorcom » Tue Apr 28, 2020 7:53 pm

Pierre,

please find attached as per your request the Xnview.INI file.
The other issue I have is that it does not show PDF thumbnails despite having the latest Ghostscript 32 and 64 version 9.52
OS is Windows 10 1909 x64
32GB RAM

Thanks!
Attachments
xnview_ini.rar
xnview.ini file
(5.13 KiB) Downloaded 5 times

User avatar
xnview
Author of XnView
Posts: 33337
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Missing tabs text in tabs and/or tabs

Post by xnview » Wed Apr 29, 2020 2:56 pm

i've tried on a clean Windows 10 x64 1909, and no problem
Pierre.

dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

Re: Missing tabs text in tabs and/or tabs

Post by dorcom » Thu Apr 30, 2020 6:40 am

It used to be fine but since about three weeks ago this started to happen.
All system check, SFC are good.
An uninstall, registry clean and reinstall resulted in the same.
🤔

User avatar
xnview
Author of XnView
Posts: 33337
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Missing tabs text in tabs and/or tabs

Post by xnview » Thu Apr 30, 2020 7:23 am

dorcom wrote:
Thu Apr 30, 2020 6:40 am
It used to be fine but since about three weeks ago this started to happen.
All system check, SFC are good.
An uninstall, registry clean and reinstall resulted in the same.
🤔
yes strange, it's the only problem?
Pierre.

dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

Re: Missing tabs text in tabs and/or tabs

Post by dorcom » Thu Apr 30, 2020 8:23 am

Pierre

You might have the answer.
I just realized that when copy and pasting more than one image into xnview they usually opened additionally and individually within the same program window but with a little generic tabs: clipboard 1, clipboard 2, clipboard 3 etc.
It does not do that anymore instead it just switches over to the image.

When I clicked on the right side of the menu bar on the "restore" (red arrow in pic: xnview1), this happened: (pic xnview2)
???

Rob
Attachments
xnview2.jpg
xnview1.jpg

dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

Re: Missing tabs text in tabs and/or tabs

Post by dorcom » Mon May 04, 2020 6:55 am

Addendum:
When I close all the windows and click on browser tree the it works again until the next restart of XnView.
See attached screen clip movie*.


PS It would be nice to post here under attachments what the max. file size is for (mp4) uploads!
Sofar I had to try 4 times! 12MB; 8MB; 4MB; 2MB; until finally a 1.5MB would upload!
Attachments
New XnView missing tabs problem.mp4
XnView missing tab clip
(1.37 MiB) Downloaded 4 times

dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

Re: Missing tabs text in tabs and/or tabs

Post by dorcom » Mon May 04, 2020 7:37 pm

xnview wrote:
Thu Apr 30, 2020 7:23 am
dorcom wrote:
Thu Apr 30, 2020 6:40 am
It used to be fine but since about three weeks ago this started to happen.
All system check, SFC are good.
An uninstall, registry clean and reinstall resulted in the same.
🤔
yes strange, it's the only problem?
I found the culprit!!! But why does it do that?
A while ago I posted here in the former question how can I have XnView start in normal mode and not full-screen as I have a huge 55" work monitor.
Logically I was looking under options> View & Fullscreen.
I was advised that the setting I am looking for to start in normal mode is under options> general. (Illogical placement to me)
At that time thereafter the problem with the blank tab started to appear.

So I re-enabled (checked) "Maximize XnView at Startup" and started the app.
Bingo! The tabs are present and remain so even if you downsize the app window.
However, when I disable (uncheck) "Maximize XnView at Startup" the phenomenon with the blank tab is present!
As all demonstrated in the 2 most recent messages with attachments.

So this is a bug! Please fix!

Rob

Please read my other most recent 2 messages with attachments as well.

dorcom
Posts: 15
Joined: Tue May 27, 2014 11:36 pm

[SOLVED] Re: Missing tabs text in tabs and/or tabs

Post by dorcom » Mon May 04, 2020 8:10 pm

Finally!
I found the cause!
Everything works now and when XnView opens in normal mode the tabs are there.

The culprit?
Laughable. In the properties for the desktop shortcut icon for XnView under "run" was set to run "minimized"!!!
Although XnView started in normal window size mode this "minimized" caused the tabs to disappear!

Set it to "normal window" and all is fine!

DUH!?

Post Reply