incorrect display of transparency.

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

Post Reply
user100
Posts: 9
Joined: Tue Apr 14, 2015 4:12 pm

incorrect display of transparency.

Post by user100 » Sun Jul 26, 2020 11:04 pm

XnView v2.49.3 but is also present in older versions

incorrect display of transparency.
In the attached archive samples.
Image



also:
low speed open JPEG 2000 files when using the plugin openjp2.dll.
When using the LuraWave plugin.jp2 Dll (lwf_jp2.dll was in older versions ) the speed is 2-4 times higher and less CPU usage.

Plugin libwebp.dll incompatible with Windows xp. But there is a compatible version.

It is advisable to add the ability to view svg files, but only if using a small plugin, without third-party components. If of course this is possible.
Attachments
Restore.zip
(4.44 KiB) Downloaded 19 times

user100
Posts: 9
Joined: Tue Apr 14, 2015 4:12 pm

Re: incorrect display of transparency.

Post by user100 » Fri Jul 31, 2020 10:49 pm

You're not interested?

User avatar
xnview
Author of XnView
Posts: 33668
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: incorrect display of transparency.

Post by xnview » Wed Aug 12, 2020 4:09 pm

user100 wrote:
Sun Jul 26, 2020 11:04 pm
XnView v2.49.3 but is also present in older versions

incorrect display of transparency.
In the attached archive samples.
Image
which file? spring.png?

low speed open JPEG 2000 files when using the plugin openjp2.dll.
When using the LuraWave plugin.jp2 Dll (lwf_jp2.dll was in older versions ) the speed is 2-4 times higher and less CPU usage.
Yes, but lurawave is an old plugin no more supported
It is advisable to add the ability to view svg files, but only if using a small plugin, without third-party components. If of course this is possible.
currently only XnView MP can load svg file
Pierre.

user100
Posts: 9
Joined: Tue Apr 14, 2015 4:12 pm

Re: incorrect display of transparency.

Post by user100 » Mon Aug 17, 2020 1:31 am

all samples in the archive are not displayed correctly.
for example you can test on Firefox.
only XnView MP can load svg file
but you don't make a version of XnView MP for Windows xp.
Maybe you can make a plugin on the Firefox sources, they are free and there's a quality decoder.

User avatar
xnview
Author of XnView
Posts: 33668
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: incorrect display of transparency.

Post by xnview » Mon Aug 17, 2020 8:12 am

user100 wrote:
Mon Aug 17, 2020 1:31 am
all samples in the archive are not displayed correctly.
for example you can test on Firefox.
only XnView MP can load svg file
but you don't make a version of XnView MP for Windows xp.
Maybe you can make a plugin on the Firefox sources, they are free and there's a quality decoder.
these PNGs use alpha on 8bits data, currently not supported by XnView
Pierre.

Post Reply