Thumbnails view bug on raw/jpeg

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: helmut, XnTriq, xnview

trance
Posts: 19
Joined: Tue Dec 07, 2021 8:35 pm

Thumbnails view bug on raw/jpeg

Post by trance »

  • Thumbnails from JPEG Images from Fujifilm S5 Pro contains black borders (the aspect ratio is 3:2)
  • The RAW (RAF) images show resolution of 3030x2036 instead of 4256x2848
  • The selected RAW images show resolution of 1516x1018 in status bar
  • The RAW image preview is lighter (or darker) than the corresponding JPEG
  • The full view of RAW image displays 1440x960 with correct colors (this should be embedded thumbnail but not the image itself)
  • The second line in thumbnails view missing last character "JPEG TrueColor (v1.1" or "S5Pr" (for all images)
The files:
https://drive.google.com/file/d/1rPM6-h ... sp=sharing
https://drive.google.com/file/d/1_8VM2r ... sp=sharing
User avatar
xnview
Author of XnView
Posts: 38269
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Thumbnails view bug on raw/jpeg

Post by xnview »

trance wrote: Wed Dec 08, 2021 8:34 am [*] Thumbnails from JPEG Images from Fujifilm S5 Pro contains black borders (the aspect ratio is 3:2)
The thumbnail contains black borders, it's not a bug
[*] The RAW (RAF) images show resolution of 3030x2036 instead of 4256x2848
[*] The selected RAW images show resolution of 1516x1018 in status bar
[*] The RAW image preview is lighter (or darker) than the corresponding JPEG
[*] The full view of RAW image displays 1440x960 with correct colors (this should be embedded thumbnail but not the image itself)
[*] The second line in thumbnails view missing last character "JPEG TrueColor (v1.1" or "S5Pr" (for all images)
with which version?
Pierre.
trance
Posts: 19
Joined: Tue Dec 07, 2021 8:35 pm

Re: Thumbnails view bug on raw/jpeg

Post by trance »

2.50.3
trance
Posts: 19
Joined: Tue Dec 07, 2021 8:35 pm

Re: Thumbnails view bug on raw/jpeg

Post by trance »

xnview

The full view of RAW files (S5 Pro) shows embedded thumbnails but not the actual file contents.
Thumbnails are 1440x960, actual file is 3030x2036.

I have a file with corruption - the thin horizontal line over the image.
in Browser Thumbnails, the line is not visible, and the image is brighter than it is (used thumbnail).
In Browser Preview, the image is darker, and the line is visible.
On Open, the image is brighter again, and line is not visible.
So, even Browser Preview shows full image, and Full View shows embedded thumbnail.
If it wasn't the line, I haven't been able to notice that the Preview shows full image.
I have created this topic a long time ago, and there were files without corruption. And what changed?
trance
Posts: 19
Joined: Tue Dec 07, 2021 8:35 pm

Re: Thumbnails view bug on raw/jpeg

Post by trance »

To view RAW, you have to go to "options - view - misc - camera raw - full size". Why it isn't by default? I can't know every setting.
Please set this to default, as well as checkerboard background for transparent PNGs.
No one need to "tweak" tool to make it work as it should work.
When you reinstall, you will forget half of the settings.

So this is the remaining:
- when "browser - preview - camera raw" is set to "half size" then the resolution in status bar is half size.
- The RAW image preview is brighter (or darker) than the corresponding JPEG
- The second line in thumbnails view missing last character

In MP, you have to go to "settings - interface - formats - read - camera raw", and set "use" to "full size", uncheck "use automatic white balance", check "use camera white balance", and it's still not the same as JPEG, and different from Classic.
Classic: more dark.
MP: too bright.
Adobe Camera Raw: as expected.

In MP, no separate settings for preview and full view, therefore preview is slow.
MP's image resolution: incorrect.

Why should I check, check, check? They force me to be a power user, but I want to be like everyone else.

The RAW files (provided in the first post) is not in sRGB color space but in Adobe RGB color space, but it shows sRGB.
User avatar
xnview
Author of XnView
Posts: 38269
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Thumbnails view bug on raw/jpeg

Post by xnview »

trance wrote: Fri May 20, 2022 5:55 pm When you reinstall, you will forget half of the settings.
??? settings are not removed
- when "browser - preview - camera raw" is set to "half size" then the resolution in status bar is half size.
Yes, it's the size of image loaded
- The RAW image preview is brighter (or darker) than the corresponding JPEG
Yes, not easy to obtain same image...
- The second line in thumbnails view missing last character
will be fixed
In MP, you have to go to "settings - interface - formats - read - camera raw", and set "use" to "full size", uncheck "use automatic white balance", check "use camera white balance", and it's still not the same as JPEG, and different from Classic.
Classic: more dark.
MP: too bright.
Do you use 'Automatic brightness'? there is a bug in MP, setting is not used
Adobe Camera Raw: as expected.
I have not the RAW engine from Adobe :(
In MP, no separate settings for preview and full view, therefore preview is slow.
you means that loading preview in MP is slower than Classic with same setting ('full size')?
The RAW files (provided in the first post) is not in sRGB color space but in Adobe RGB color space, but it shows sRGB.
Currently icc from RAW is not applied...
Pierre.