Checkerboard background doesn't show in some cases.

Bugs found in XnView Classic. Please report only one bug per topic!

Moderators: XnTriq, xnview

goldnick7
Posts: 11
Joined: Sun Mar 03, 2019 12:59 pm

Checkerboard background doesn't show in some cases.

Post by goldnick7 »

Here is a transparent png image we found that when you enable the option --> Use checkerboard pattern as background ... the checkerboard doesn't work, it doesn't show.

Edit: even converting it with ffmpeg, or ImageMagick, or other tools, or opening with Photoshop and saving as png.. or resizing.. nothing seems to fix the issue of the checkerboard not showing with this image.
User avatar
xnview
Author of XnView
Posts: 36821
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Checkerboard background doesn't show in some cases.

Post by xnview »

checkerboard is shown for 32bits image
Pierre.
goldnick7
Posts: 11
Joined: Sun Mar 03, 2019 12:59 pm

Re: Checkerboard background doesn't show in some cases.

Post by goldnick7 »

xnview wrote: Wed Jan 05, 2022 7:39 am checkerboard is shown for 32bits image
So this is intended behavior? What does it matter what bit rate the image have with the XnView Classic background tho?

Why does the checkerboard show inside Photoshop and any other Image viewing program I've tested this image with? Even XnView MP shows the checkerboard background.
User avatar
xnview
Author of XnView
Posts: 36821
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Checkerboard background doesn't show in some cases.

Post by xnview »

goldnick7 wrote: Wed Jan 05, 2022 5:48 pm Why does the checkerboard show inside Photoshop and any other Image viewing program I've tested this image with? Even XnView MP shows the checkerboard background.
Classic was always like that, MP use better behavior
Pierre.