Exiftool: "Author keeps the "" - quotes

All non-XnView related: softwares, formats, imaging, photography...

Moderators: XnTriq, xnview

Post Reply
User avatar
Peter2
XnThusiast
Posts: 1113
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Exiftool: "Author keeps the "" - quotes

Post by Peter2 » Thu Sep 11, 2008 7:33 am

I use exiftool with this code:

Code: Select all

exiftool.exe -Author="I am the test author" "Test.pdf"
The result in PDF is that the "author is the only data which keeps it quotes:
"I am the test author"
Is this correct? Is there a way to avoid this?

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

User avatar
Peter2
XnThusiast
Posts: 1113
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Post by Peter2 » Thu Sep 18, 2008 8:22 pm

No exiftool-specialists here?

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Post by oops66 » Fri Sep 19, 2008 3:49 pm

Peter2 wrote:No exiftool-specialists here?
Peter
Hello,
FYI: I'm not a specialist but I have tried your ExifTool command line under my system (linux: Ubuntu 8.04 + Exiftool V7.43 perl + My default PDF reader: Evince v2.22.2 ) and I have not "your quotes problems" even for the Author item:

Code: Select all

exiftool -Author="I am the test author" "test.pdf"
The result in the PDF via Evince, is without quotes:
I am the test author
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Peter2
XnThusiast
Posts: 1113
Joined: Thu Nov 24, 2005 3:07 pm
Location: CH

Post by Peter2 » Fri Sep 19, 2008 5:01 pm

Maybe a Windows probelm? I just looked at a PDF, made from Word with PDF-Creator, where the "author in PDF" was taken from "author in Word": In Word no quotes, but in PDF :?: :?:

Peter
XnView 2.48 German, Win 7 x64 Prof. / Win 10

Post Reply