A: Options - Fullscreen - Text Font: not applied instantly

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

A: Options - Fullscreen - Text Font: not applied instantly

Post by GeorgD »

Nothing urgent but shall be corrected, maybe in 1.9.1

Go to Fullscreen mode. Press F12. Go to "Options - Fullscreen - Text settings - choose Font" and select another font type, size or shape. Press everywhere OK. The font is not applied, until you leave fullscreen and re-enter it again. Makes it aannoying to set fitting font & size & shape. Strangely, font color is remembered instantly.

BTW: "Options - Fullscreen - dual monitor, strech over all monitors" requires leave and re-enter full screen as well.
ckit
XnThusiast
Posts: 2451
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

I cannot reproduce this bug using XnView 1.90 beta 1.
XnViewMP running on Windows 10 Pro x64 21H1
PhotoFiltre 11, PowerArchiver Toolkit, ShareX and Vivaldi Browser
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh »

Font settings are immediately applied in browser, but not viewer. I don't know if each browser vs viewer difference is a bug though.
-->Confirmed.
ckit
XnThusiast
Posts: 2451
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

Confirmed.

My first attempt was from the browser but I didn't try from View mode!
XnViewMP running on Windows 10 Pro x64 21H1
PhotoFiltre 11, PowerArchiver Toolkit, ShareX and Vivaldi Browser
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France

Works here

Post by Clo »

:) Hello !

• Following exactly the Georg's steps, I get alright the font and the colours at the first time when using full screen in “View”.

• Accuracy : I have opened an image in “View” before to perform the test - change the settings-

:?:

- Windows XP-Pro SP1. 1.90 ß-1

:mrgreen: KR
Claude
Clo
Last edited by Clo on Fri Dec 01, 2006 3:00 am, edited 1 time in total.
Old user ON SELECTIVE STRIKE till further notice
User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Re: Works here

Post by GeorgD »

> Font settings are immediately applied in browser, but not viewer. I don't know if each browser vs viewer difference is a bug though.

>Accuracy : I have opended an image in “View” before to perform the test - change the settings-

Hm, seems like I shall have printed in bold "Go to Fullscreen mode." and then continued like "and THERE press F12 for options". Now done 8)

The :bug: for my workflow is, that I have to leave full screen and re-enter full screen. That makes it even more tedious to see what font shape/size/... looks good, e.g. on a beamer, than it already is (8 or even more keys/clicks needed).

/Georg
ckit
XnThusiast
Posts: 2451
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

Fixed in Beta 2.
XnViewMP running on Windows 10 Pro x64 21H1
PhotoFiltre 11, PowerArchiver Toolkit, ShareX and Vivaldi Browser
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh »

Fixed for me in ß-2.
User avatar
GeorgD
Posts: 283
Joined: Thu Oct 12, 2006 2:45 pm

Post by GeorgD »

marsh wrote:Fixed for me in ß-2.
confirmed :D