B2: Not prompted to save changes

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
Drahken
Posts: 884
Joined: Sun Apr 10, 2005 4:29 pm

B2: Not prompted to save changes

Post by Drahken »

I opened xnview, opened a view images, made a quick change to each, closed xnview, got a "save, yes/no?" prompt and a "apply to all?" checkbox. I checked to apply to all, then clicked "no". Xnview closed without saving the changes (as intended). However, now it no longer prompts me to save changes to any images, the "no to all" is stuck on, and there's no way to turn it back off.


Edit: Ironically, I think this way suits my personal needs better. However, it's not the expected behavior (it should only be a temporary setting which reverts the next time you open the prog). Also, the fact that the only way you can change it back is by editting the ini file is a major problem regardless. You could leave it as a permanent setting like it is now, but just add an option somewhere to undo it. Indeed, maybe make it something you can set completely from within options. Put something either on the general->misc page or the sys integration page where you can choose "always save", "never save", "ask each time".
Last edited by Drahken on Fri Dec 01, 2006 9:14 pm, edited 1 time in total.
Oh the feuhrer, oh the feuhrer, oh the feuhrer's nipples bonk!
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh »

Confirmed.
Meanwhile, I think it can be reset by changing the following INI as shown:

ShowSaveDlg=0
User avatar
xnview
Author of XnView
Posts: 36866
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: B2: Not prompted to save changes

Post by xnview »

Drahken wrote:I opened xnview, opened a view images, made a quick change to each, closed xnview, got a "save, yes/no?" prompt and a "apply to all?" checkbox. I checked to apply to all, then clicked "no". Xnview closed without saving the changes (as intended). However, now it no longer prompts me to save changes to any images, the "no to all" is stuck on, and there's no way to turn it back off.
Ok, right i don't save thi setting
Pierre.
ckit
XnThusiast
Posts: 2451
Joined: Tue Feb 17, 2004 1:11 am
Location: Cabarlah, Australia

Post by ckit »

Fixed in Beta 3.
XnViewMP running on Windows 10 Pro x64 21H1
PhotoFiltre 11, PowerArchiver Toolkit, ShareX and Vivaldi Browser