[1.96] Batch Rename #### > 1000

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

Post Reply
User avatar
Anika
Posts: 85
Joined: Wed Jul 28, 2004 12:18 pm

[1.96] Batch Rename #### > 1000

Post by Anika » Tue May 05, 2009 12:41 pm

The batch rename dialog has a problem with file numbers bigger than 1000.

How to reproduce the error:
1 Select one or more pictures
2 open the dialog batch rename
3 use a file name with #### starting with a number larger than 1000 and rename
then repeat step 1 and 2.

in step 3 you will see an suggested starting number of 1.000 and the numbering will start at 0001.

Hope you can fix it easily.
Kind regards,
Anika
XnView 2.04, 2.13 Windows 2000 SP4 and Windows XP SP3 and Windows 7 64bit

User avatar
xnview
Author of XnView
Posts: 31889
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: [1.96] Batch Rename #### > 1000

Post by xnview » Tue May 05, 2009 2:18 pm

Anika wrote: in step 3 you will see an suggested starting number of 1.000 and the numbering will start at 0001.
Where do you have 0001? I have 1000 as expected
Pierre.

User avatar
Anika
Posts: 85
Joined: Wed Jul 28, 2004 12:18 pm

Re: [1.96] Batch Rename #### > 1000

Post by Anika » Tue May 05, 2009 3:18 pm

Image

Perhaps there is a problem with a german windows?
XnView 2.04, 2.13 Windows 2000 SP4 and Windows XP SP3 and Windows 7 64bit

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: [1.96] Batch Rename #### > 1000

Post by marsh » Tue May 05, 2009 3:29 pm

Anika wrote: Perhaps there is a problem with a german windows?
Aha, the same with "," seperator. Though typing in 1234 works.

User avatar
helmut
Posts: 8174
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: [1.96] Batch Rename #### > 1000

Post by helmut » Wed May 06, 2009 9:32 am

Well spotted. Looks as if the comma and point are interpreted as decimal point.

User avatar
Anika
Posts: 85
Joined: Wed Jul 28, 2004 12:18 pm

Re: [1.96] Batch Rename #### > 1000

Post by Anika » Thu May 14, 2009 11:56 am

Thanks, the problem is solved with 1.96.1
XnView 2.04, 2.13 Windows 2000 SP4 and Windows XP SP3 and Windows 7 64bit

Post Reply