XnView 1.97B1 = bug w/ associated programs

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

Post Reply
deejjjaaaa
Posts: 24
Joined: Tue Dec 23, 2008 8:48 pm

XnView 1.97B1 = bug w/ associated programs

Post by deejjjaaaa » Tue Nov 03, 2009 3:22 am

XnView 1.97B1 = bug w/ associated programs

does not read the existing list of associated programs ( [OpenWith] section ) from xnview.ini

does add programs there through local menu (they will appear in .ini file), but they will not appear in the local menu, after that - local menu will always come empty (w/o any associated programs)

the same thing if I switch to use registry instead of .ini file

ckit
XnThusiast
Posts: 2444
Joined: Tue Feb 17, 2004 1:11 am

Re: XnView 1.97B1 = bug w/ associated programs

Post by ckit » Tue Nov 03, 2009 3:42 am

I cannot confirm, both PhotoFiltre Studio and Paint.NET from 1.96.5 INI work fine and I just added "ACDSee Photo Editor 2008" to the list and that works fine too.

I won't try the registry method as I prefer working with INI's for XnView.
Windows 10 Pro x64 1903
XnViewMP and Classic and PhotoFiltre Studio X

User avatar
xnview
Author of XnView
Posts: 31799
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView 1.97B1 = bug w/ associated programs

Post by xnview » Tue Nov 03, 2009 7:54 am

I can't confirm too
Pierre.

deejjjaaaa
Posts: 24
Joined: Tue Dec 23, 2008 8:48 pm

Re: XnView 1.97B1 = bug w/ associated programs

Post by deejjjaaaa » Tue Nov 03, 2009 5:49 pm

xnview wrote:I can't confirm too
let me describe the situation from yesterday

1) I was running 1.96.5 on XP/SP3
2) downloaded 1.97B1 zip, replaced (copy over) everything in 1.96.5 folder
3) started 1.97B1
4) saw the bug, tried to change the option to store the configuration from .INI to registry - did not help, back from registry to .INI - did no help either
5) removed 1.97B1
6) installed 1.96.5 (old .INI file stayed)
7) everything is working as it was supposed to work

should I try again ? anything particular that I need to pay attention to try to reproduce the bug ? thx

deejjjaaaa
Posts: 24
Joined: Tue Dec 23, 2008 8:48 pm

Re: XnView 1.97B1 = bug w/ associated programs

Post by deejjjaaaa » Tue Nov 03, 2009 6:09 pm

bug is there - here is a screenshot after I repeated the steps today

you can see the content of the .INI file of the right side and what I can see in the local menu on the left side... no items displayed (should be 2 items - Photoshop and C1)

Image

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: XnView 1.97B1 = bug w/ associated programs

Post by oops66 » Tue Nov 03, 2009 7:56 pm

FI: I have the same problem into the Browser mode (but it works into View Mode)
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
xnview
Author of XnView
Posts: 31799
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView 1.97B1 = bug w/ associated programs

Post by xnview » Wed Nov 04, 2009 8:55 am

Oh right, with the popup, not in the menu
Pierre.

User avatar
JohnFredC
XnThusiast
Posts: 2010
Joined: Wed Mar 17, 2004 8:33 pm
Location: Sarasota Florida

Re: XnView 1.97B1 = bug w/ associated programs

Post by JohnFredC » Sat Nov 07, 2009 3:16 pm

Not fixed in b2
John

User avatar
xnview
Author of XnView
Posts: 31799
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnView 1.97B1 = bug w/ associated programs

Post by xnview » Sat Nov 07, 2009 4:04 pm

JohnFredC wrote:Not fixed in b2
Yes, in b3
Pierre.

Post Reply