1.98ß2 - Bug in multipage TIFF printing (pg range)

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Fri Mar 25, 2011 10:25 am

Hello, Pierre.

Printing a range of pages from a multipage TIFF file results in not all pages included in range.

For instance, I tried to print the last and the one before last pages from a 114 multipage TIFF (print pages 113 - 114) and XNView only printed page 113 and it said (1 page selected). It should be two pages selected.

Best regards.
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

User avatar
xnview
Author of XnView
Posts: 27895
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby xnview » Wed Apr 13, 2011 1:23 pm

Please try 1.98 beta3
Pierre.

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Thu Apr 14, 2011 8:12 am

I regret to inform that this issue ISN'T RESOLVED yet (1.98ß3). Printing a multipage tiff (148 pages) pages from 9 to 11 it will print just TWO PAGES (instead of three).
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

User avatar
xnview
Author of XnView
Posts: 27895
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby xnview » Wed Apr 27, 2011 10:49 am

I can't reproduce, could you send me the tiff file?
Pierre.

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Thu Apr 28, 2011 7:33 am

I will. Thanks. Anyway I will do another test just to be sure I was still using ß2 or something.
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Thu Apr 28, 2011 11:09 am

Hello again. I made sure I was using latest ß3 and the issue is still there.

I am sending you a test file (TIFF). When printing page range 5-7 (3 pages) Xnview just says pages 1 out of 2.

Link (about 630 KB) -> http://www.megaupload.com/?d=3MBKNYQE
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

User avatar
xnview
Author of XnView
Posts: 27895
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby xnview » Thu Apr 28, 2011 12:56 pm

I've tried, but i have 'Page 1/3'
You change page range in Printer tab?
Pierre.

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Thu Apr 28, 2011 7:42 pm

That's weird. What do you mean by changing printer range in printer tab? I just entered from page 5 to page 7 at the boxes. I didn't touch anything else. Maybe I am doing something wrong. I will keep you posted.

EDIT: Tried at my home computer. Same issue. Entered pages from 5 to 7. On the right pane, preview says pages 1/2

EDIT2: I installed ß3 over 1.98. I am going to try installing it on a separate folder...

EDIT3: Installing in a new clean folder did nothing. Same as before. ???
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

User avatar
xnview
Author of XnView
Posts: 27895
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby xnview » Fri Apr 29, 2011 2:06 pm

eL_PuSHeR wrote:EDIT: Tried at my home computer. Same issue. Entered pages from 5 to 7. On the right pane, preview says pages 1/2

I have 1/3 :( i don't understand...
Pierre.

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Fri Apr 29, 2011 8:38 pm

Me neither. I have run out of ideas. Maybe someone else could test this.
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby marsh » Sun May 01, 2011 6:54 am

Where print function is launched makes a difference. In view mode, range 1-1 reads 1/0 in righthand preview (1/1 correct from a browser window).
Other settings: Read ahead off.

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Sun May 01, 2011 9:29 am

Thanks for testing. For me it seems it's always wrong. I was unable to find the "read ahead" option in config. Where is it? And how do you enter "View mode".

I tried with browser disabled and enabled and it's always wrong.
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby marsh » Sun May 01, 2011 9:50 am

The navigating cache is at Options... View>{Misc}>[ ]Read one image ahead

I think this picture is a good overview:
Image
Unmaximizing icon at menu level reveals 2 types of subwindows: unique browser and images.
View mode - an image is in the foreground (edit functions are available).
Browser mode - its window is in the foreground (file list, preview, tree available).
Basic mode - all subwindows closed.

eL_PuSHeR
Posts: 265
Joined: Sat Apr 25, 2009 9:23 am

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby eL_PuSHeR » Sun May 01, 2011 2:14 pm

I have removed the "read ahead" option. No change for me.
Intel i7 5960X
Gigabye GA-X99-Gaming 5
8 GB DDR4 (2100)
GeForce GTX 970 (Gigabyte)

kimi
Posts: 28
Joined: Sat Apr 23, 2011 4:52 pm

Re: 1.98ß2 - Bug in multipage TIFF printing (pg range)

Postby kimi » Wed Dec 07, 2011 4:25 pm

I have the same problem with 1.98, i used to print multi-page Tiffs with no problem, but that time, when i deselect "insert all pages...." and select a range, the preview not generated correctly, plus the printed file isn't the one i desired. Reverting back to 1.96 solved the issue.

I also get a 1/0 in the bottom of preview window. That really seems a new bug, and drives me crazy.

That means newer versions are NOT always better!


Return to “Classic - Resolved Bugs & Requests”

Who is online

Users browsing this forum: No registered users and 1 guest