Slideshow goes forward in steps of two.

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Slideshow goes forward in steps of two.

Post by marsh »

With mouse, slideshow (Ctrl+L) advances to next picture in steps of two:
1, 3, 5, 7... (skipping files 2, 4, 6).
Advancing to next picture works normally with keyboard.
(This also occurs with slide.exe)
User avatar
xnview
Author of XnView
Posts: 36798
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Slideshow goes forward in steps of two.

Post by xnview »

marsh wrote:With mouse, slideshow (Ctrl+L) advances to next picture in steps of two:
1, 3, 5, 7... (skipping files 2, 4, 6).
Advancing to next picture works normally with keyboard.
(This also occurs with slide.exe)
only with slide.exe?
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Slideshow goes forward in steps of two.

Post by marsh »

xnview wrote:
marsh wrote:With mouse, slideshow (Ctrl+L) advances to next picture in steps of two:
1, 3, 5, 7... (skipping files 2, 4, 6).
Advancing to next picture works normally with keyboard.
(This also occurs with slide.exe)
only with slide.exe?
Both slideshow and slide.exe. v.1.82.4
---
Update: it only occurs with transition effects turned off.
User avatar
xnview
Author of XnView
Posts: 36798
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Slideshow goes forward in steps of two.

Post by xnview »

marsh wrote:
xnview wrote:
marsh wrote:With mouse, slideshow (Ctrl+L) advances to next picture in steps of two:
1, 3, 5, 7... (skipping files 2, 4, 6).
Advancing to next picture works normally with keyboard.
(This also occurs with slide.exe)
only with slide.exe?
Both slideshow and slide.exe. v.1.82.4
---
Update: it only occurs with transition effects turned off.
Could you tell me which settings do you have? I can't reproduce...
Pierre.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Slideshow goes forward in steps of two.

Post by marsh »

xnview wrote:
marsh wrote:
xnview wrote: only with slide.exe?
Both slideshow and slide.exe. v.1.82.4
---
Update: it only occurs with transition effects turned off.
Could you tell me which settings do you have? I can't reproduce...
Settings:
[x]Use keyboard/mouse
[x]Fullscreen
[ ]Use Random Order
[ ]Loop

Use Transition Effects [None] *This is problem setting for me*
More Options:
[ ]Stretch Small Pictures
[ ]Stretch Small Videos
[ ]Use High Quality
[x]Center Window
[x]No Title bar
[x]Use Gamma setting in exe/scr
[ ]Suppress read errors
[ ]Save relative paths in SLD
-All caches off.

Using right button (forward) skips files, LMB does not, keys do not.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh »

Update (using above settings):
When end is reached, a crash occurs with odd number of images 7, but not an even number 8.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh »

All fixed in 1.9alpha.