Some issues with User-defined selection ratio

Bugs and Suggestions in XnView Classic which have been resolved

Moderators: XnTriq, xnview

User avatar
helmut
Posts: 8240
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Some issues with User-defined selection ratio

Post by helmut »

The user-defined selection ratio seems to be somewhat broken (at least for me it seems to behave wrongly).

To reproduce:

1.) Select an area with a ratio 1.5 for example.
2.) Save the selection ratio using "Edit > Selection ratio > Save selection as custom"
3.) Select an area with a different ratio (1.3 for example)
4.) Press 'C' to restore the user-defined selection ratio
--> Nothing happens (bug :bug:)

5.) Choose "Edit > Selection ratio > Custom"
--> A selection is recalculated, but the selection is larger than the image (bug :bug:)

If the bug in 5.) did not occur, press "Tab" to swap selection width & height
--> A selection is recalculated, but the selection is larger than the image (bug :bug:)
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Re: Some issues with User-defined selection ratio

Post by marsh »

helmut wrote:The user-defined selection ratio seems to be somewhat broken (at least for me it seems to behave wrongly).

To reproduce:

1.) Select an area with a ratio 1.5 for example.
2.) Save the selection ratio using "Edit > Selection ratio > Save selection as custom"
3.) Select an area with a different ratio (1.3 for example)
4.) Press 'C' to restore the user-defined selection ratio
--> Nothing happens (bug :bug:)
Confirmed. Custom ratio does not work in v.1.82.4. It last worked in v.1.8.03
helmut wrote: 5.) Choose "Edit > Selection ratio > Custom"
--> A selection is recalculated, but the selection is larger than the image (bug :bug:)

If the bug in 5.) did not occur, press "Tab" to swap selection width & height
--> A selection is recalculated, but the selection is larger than the image (bug :bug:)
Confirmed. It is not recalculated properly when switched 90 degrees.
User avatar
helmut
Posts: 8240
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

Thank you for checking and confirming, marsh. I think that selecting and cropping is an often used feature, so I think this should be fixed very soon.
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

Post by marsh »

Mentioned in changelog but it still has problems in beta-1:

After choosing "C" custom ratio, this custom number does not appear in status bar.
After pressing Tab, selection box simply decreases in size instead of being shifted 90 degrees.

(I'm moving the similar companion article to this to new/open as well for further checking- since it is also in changelog.)
User avatar
helmut
Posts: 8240
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

Yes, there's still problems. -> Confirmed.
User avatar
xnview
Author of XnView
Posts: 36798
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

helmut wrote:Yes, there's still problems. -> Confirmed.
Problems from the first post??? I can't reproduce it with the beta...
Pierre.
User avatar
helmut
Posts: 8240
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

xnview wrote:
helmut wrote:Yes, there's still problems. -> Confirmed.
Problems from the first post??? I can't reproduce it with the beta...
I've just done some quick testing, this still doesn't work properly. For example:
1. Make a selection
2. Save as selection size
3. Make a selection
4. Save as selection ratio
5. Restore the selection using menu "Edit > Set Selection ratio > Custom"
6. Press Tab
7. Press Tab
-> The selection will get smaller and smaller :bug: but will not swap :bug:

The problem seems to be related with the two saved selections (Saved selection ratio and saved selection size).
User avatar
helmut
Posts: 8240
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

Verified fixed in Beta 2. -> Closed.