Upgrade fro 2.54 to 2.66

Discussions on GFL SDK, the graphic library for reading and writing graphic files

Moderators: XnTriq, xnview

linojr99
Posts: 8
Joined: Thu Feb 15, 2007 3:57 pm

Upgrade fro 2.54 to 2.66

Post by linojr99 »

:(
I'm have a problem upgrading.
Many of its functions simply don't work now, i.e. they give an error about using a null reference object. I have tried different things but nothing works.
And such things are undocumented.

Some of the items I tried are AutomaticContrast, AutoLevels, ReduceNoise, EnhanceDetail, EnhanceFocus, Equalize, FocusRestoration, LogCorrection, Normalize.
User avatar
xnview
Author of XnView
Posts: 36866
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: Upgrade fro 2.54 to 2.66

Post by xnview »

linojr99 wrote::(
I'm have a problem upgrading.
Many of its functions simply don't work now, i.e. they give an error about using a null reference object. I have tried different things but nothing works.
And such things are undocumented.

Some of the items I tried are AutomaticContrast, AutoLevels, ReduceNoise, EnhanceDetail, EnhanceFocus, Equalize, FocusRestoration, LogCorrection, Normalize.
Yes, ther is an error, i'll update a version tomorrow...
Pierre.
User avatar
Grincheux
Posts: 33
Joined: Thu Nov 30, 2006 8:01 am
Location: Arbois - 39

Post by Grincheux »

I have the same error and decided to return back to the 2.54... :x
Kenavo.
linojr99
Posts: 8
Joined: Thu Feb 15, 2007 3:57 pm

Post by linojr99 »

Has the null refreance object been corrected? :?:
User avatar
xnview
Author of XnView
Posts: 36866
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Post by xnview »

linojr99 wrote:Has the null refreance object been corrected? :?:
Yes
Pierre.