Why is GFL SDK contacting mail.boxtorrents.com?

Discussions on GFL SDK, the graphic library for reading and writing graphic files

Moderators: XnTriq, xnview

Post Reply
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Why is GFL SDK contacting mail.boxtorrents.com?

Post by brotondi »

Why is GFL SDK contacting mail.boxtorrents.com (81.52.143.6)?

This was not with SDK 1.9... and I found no documentation about this...

Bruno
User avatar
xnview
Author of XnView
Posts: 33915
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Why is GFL SDK contacting mail.boxtorrents.com?

Post by xnview »

brotondi wrote:Why is GFL SDK contacting mail.boxtorrents.com (81.52.143.6)?

This was not with SDK 1.9... and I found no documentation about this...

Bruno
????? How do you have that??
Pierre.
User avatar
helmut
Posts: 8219
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Re: Why is GFL SDK contacting mail.boxtorrents.com?

Post by helmut »

brotondi wrote:Why is GFL SDK contacting mail.boxtorrents.com (81.52.143.6)?
GFL SDK does not establish any internet connections. Perhaps your package or application is corrupted. Where did you get your GFL SDK from?
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Post by brotondi »

Sorry for not responding, I got no Reply-Notification - and was very busy after a HD-Crash...

I downloaded the Package from http://perso.orange.fr/pierre.g/xnview/ ... adgfl.html (V2.54)
... now let's give v2.67 a try :)

... be back after some tests...

Bruno
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Post by brotondi »

hmmm really strange: I set back my system to a point where 1.90 was installed and compiled my project: Everything o.k.

now I really only changed gflib.bas to V2.67 and compiled -> exe connects to status-d.icq.com:DNS...

turned gflib.bas back to V1.90, compiled, but still contacting...

excluded gflib.bas from the project (because not needed) and now no connecting...

???

(ZoneAlarm is showing me this information instantly after executing the exe)
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Post by brotondi »

... still working on it, but it seems to be a side-effect from something else, has nothing to do with your SDK...
MaierMan
Posts: 78
Joined: Wed Aug 04, 2004 8:32 pm
Contact:

Post by MaierMan »

Might be some DLL that is "injected" into your project from the outside.
(Either something valid or some kind of malware).

SysInternals ProcessExplorer is a great tool to see all loaded modules (and even some minor debugging information).

I'm pretty sure: not the fault of libgfl.dll
User avatar
brotondi
Posts: 129
Joined: Wed Feb 01, 2006 8:16 am

Post by brotondi »

o.k. 95% clear: My fault: When Installing 2.54 I changed some Internet-Setting in the project which also resettet when turning back to 1.90 (so the bug apeared only with 2.54 but not with 1.90) ... but really had nothing to do with your SDK. Sorry!

... and now going to bed :)

Greetgins

Bruno
Post Reply