b1: Thumbnails for folders - not cached

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

b1: Thumbnails for folders - not cached

Post by robc » Sat Dec 17, 2005 8:33 am

If you have caching enabled, the thumbnail for a folder gets correctly created and saved; if subsequently you add pictures inside that folder, the corresponding thumbnail for the folder gets recreated every time - the cache file for the containing folder seems not to get updated. You need to manually delete the corresponding cache file and recreate it, but if you add more files the whole thing restarts again.

User avatar
xnview
Author of XnView
Posts: 33667
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: b1: Thumbnails for folders - not cached

Post by xnview » Sat Dec 17, 2005 4:41 pm

robc wrote:If you have caching enabled, the thumbnail for a folder gets correctly created and saved; if subsequently you add pictures inside that folder, the corresponding thumbnail for the folder gets recreated every time - the cache file for the containing folder seems not to get updated. You need to manually delete the corresponding cache file and recreate it, but if you add more files the whole thing restarts again.
I confirm
Pierre.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Tue Dec 20, 2005 2:12 pm

Well, I've checked in b1 and b2 and it seems that problems disappeared in b2 (in b1 I noticed recreating folder thumbnail after adding a file, in b2 it seemed there was no recreation).

However, it is hard to spot.

X.

User avatar
helmut
Posts: 8217
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut » Tue Dec 20, 2005 6:01 pm

Xyzzy wrote:Well, I've checked in b1 and b2 and it seems that problems disappeared in b2 (in b1 I noticed recreating folder thumbnail after adding a file, in b2 it seemed there was no recreation).

However, it is hard to spot.

X.
Thank you for verifying, Xyzzy. Let's see whether Rob can also confirm.

User avatar
robc
Posts: 164
Joined: Mon Nov 14, 2005 12:53 pm

Post by robc » Tue Dec 20, 2005 9:22 pm

Sorry I didn't reply before: I can confirm it has been fixed :D

Locked