RC1: Parent folder ".." is always on (only my ini)

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

RC1: Parent folder ".." is always on (only my ini)

Post by ckv » Sat Jan 14, 2006 11:44 pm

As the subject says the parent folder ".." is always on regardless of the options. This doesn't occur with clean ini t and my ini is created by RC1, so this isn't ini incompatibility bug.

Get my ini: [EDIT]
Last edited by ckv on Thu Jan 19, 2006 11:23 pm, edited 1 time in total.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Sat Jan 14, 2006 11:49 pm

Here parent folder [..] is not displayed with your ini in thumbnails view.
XP SP2

X.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Post by Dreamer » Sun Jan 15, 2006 1:36 am

Xyzzy wrote:Here parent folder [..] is not displayed with your ini in thumbnails view.
XP SP2

X.
Strange, I can confirm this bug. Could you try again please?

I had similar bug, we should test this option more (items displayed).

Xyzzy
Posts: 652
Joined: Tue Nov 23, 2004 10:17 pm
Location: Poland

Post by Xyzzy » Sun Jan 15, 2006 1:13 pm

Strange, now I get it too. Maybe I did something wrong at the first time.
Confirmed.
X.

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: Parent folder ".." is always on (only my

Post by xnview » Tue Jan 17, 2006 9:52 am

ckv wrote:As the subject says the parent folder ".." is always on regardless of the options. This doesn't occur with clean ini t and my ini is created by RC1, so this isn't ini incompatibility bug.

Get my ini: xnview.ini
Yes, it's normal, you have filter on 'All' and not 'Custom'
Pierre.

User avatar
Dreamer
XnThusiast
Posts: 4605
Joined: Sun Jul 25, 2004 9:08 pm
Location: Slovakia

Re: RC1: Parent folder ".." is always on (only my

Post by Dreamer » Tue Jan 17, 2006 10:53 pm

xnview wrote:
ckv wrote:As the subject says the parent folder ".." is always on regardless of the options. This doesn't occur with clean ini t and my ini is created by RC1, so this isn't ini incompatibility bug.

Get my ini: xnview.ini
Yes, it's normal, you have filter on 'All' and not 'Custom'
So no bug? But it could be confusing, there should be at least some note in Options about this 'conflict' with filter option.

(Moved to New/Open)

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: Parent folder ".." is always on (only my

Post by xnview » Wed Jan 18, 2006 4:39 am

Dreamer wrote:
xnview wrote:
ckv wrote:As the subject says the parent folder ".." is always on regardless of the options. This doesn't occur with clean ini t and my ini is created by RC1, so this isn't ini incompatibility bug.

Get my ini: xnview.ini
Yes, it's normal, you have filter on 'All' and not 'Custom'
So no bug? But it could be confusing, there should be at least some note in Options about this 'conflict' with filter option.

(Moved to New/Open)
It's not a conflitc but a choice of the user. But how to show it?
Pierre.

Guest

Re: RC1: Parent folder ".." is always on (only my

Post by Guest » Wed Jan 18, 2006 1:14 pm

xnview wrote:It's not a conflitc but a choice of the user. But how to show it?
Use different icon when filter other than Custom is applied.
Rename 'Items displayed' to 'Custom filter' in options.

X.

User avatar
xnview
Author of XnView
Posts: 33651
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: RC1: Parent folder ".." is always on (only my

Post by xnview » Wed Jan 18, 2006 1:17 pm

Anonymous wrote:
xnview wrote:It's not a conflitc but a choice of the user. But how to show it?
Use different icon when filter other than Custom is applied.
Rename 'Items displayed' to 'Custom filter' in options.
But items displayed was a requested change :-(
Pierre.

Guest

Re: RC1: Parent folder ".." is always on (only my

Post by Guest » Wed Jan 18, 2006 2:33 pm

xnview wrote: But items displayed was a requested change :-(
So also add description (in next version) to Items displayed options page, something like 'Please choose... (Custom Filter)'. User should easier connect these features; and Close for now.

X.

User avatar
ckv
Posts: 786
Joined: Wed Feb 02, 2005 2:30 pm
Location: Glow
Contact:

Post by ckv » Wed Jan 18, 2006 2:55 pm

Close please.

The bug I describe was normal behavior depending on used options. If you want to change this behavior, please make a new request for it.
XnView Tweak UI - Tool to customize your XnView beyond the regular XnView options.
UI-less Settings - Documentation of all the hidden settings in XnView.
XFAM - Tool to create and customize XnView file associations.

Locked