[Fixed]Sepia adjustment not working right.

Bugs and Issues in 1.82 Test versions which have been fixed and verified as resolved.

Moderators: XnTriq, xnview

Locked
marsh
XnThusiast
Posts: 2443
Joined: Sun May 15, 2005 6:31 am

[Fixed]Sepia adjustment not working right.

Post by marsh »

Image>Map>Sepia... The slider has too limited range. 0 to -1.
Image
------
Fixed v.1.82.3
------
Last edited by marsh on Mon Apr 10, 2006 11:56 pm, edited 1 time in total.
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Worse…

Post by Clo »

:) Hello B. !

• Here, I can't adjust anything with the slider.
- It's cursor comes back always to left, like tied with a spring !
- Not “Sepia” effect at all, the pic turns grey, no more…
- Tested with a PNG 24 BPP - Under Win XP-Pro

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
ckit
XnThusiast
Posts: 2449
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit »

Confirmed, this feature has major problems!

Also, there should no asian symbols it should say "Sepia" for window title.
XnView MP 64bits and Windows 10 Pro x64 20H2
PhotoFiltre Studio X
ckit
XnThusiast
Posts: 2449
Joined: Tue Feb 17, 2004 1:11 am
Contact:

Post by ckit »

Ok, I got mine working after playing around with some of the other Map tools.
However, the asian window title has to be fixed!
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Just a bullet…

Post by Clo »

—> ckit

:) Hello !

- Strange, here I've not any weird characters in the title-bar… even no title at all … except a bullet “•” #149.
But I tested with language-DLLs (Fr¦En¦Ger)… I'll search where this dialogue is located in the DLL, and will attempt to set a correct title…
Anyway, I can't get the function working yet…

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Error !

Post by Clo »

—> marsh

:) Hello B. !
Image> Map> Sepia... The slider has too limited range. 0 to -1.
:P This is not an adjustment slider, this is a scroll-bar ! Image
- Indeed, it could work the same, since it has appropriate codes (it seems…), but it doesn't !
- Moreover, the captions are false (even quite missing in the language-DLLs) for the applied ratio !
We might get something like :
  
  0 —————nn————— 100
- “nn…” = Current adjusted ratio in %.

- However, this is very easy to fix up (at least for me in the DLLs…)
- About the dialogue-title, there is no caption in the dialogue, it might come from a scrip of the "Strings" resources…
- But, like I said above, even if I write the title-caption, I get only a bullet “•” :?
- In my experimental DLLs (Pierre has them), the only “•” as a single character I wrote is in the "Rename file" dialogue (rename a single file), to replace the tiny dot "." between the name and the extension.
- Hence, this could be an indication for Pierre, perhaps…
- Maybe some “salad” in the EXE with these two dialogues codes ?
- Anyway, like we say in French : « There is a Imagein the cheese !»

:wink: I guess you trapped a nice game !

Note : “Sepia” works quite fine in the 1.80.3, I verified…

:mrgreen: Kind regards,
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice
User avatar
helmut
Posts: 8220
Joined: Sun Oct 12, 2003 6:47 pm
Location: Frankfurt, Germany

Post by helmut »

In 1.82.2 the Sepia functionality is completely broken, I think. Time for a 1.82.3...
User avatar
xnview
Author of XnView
Posts: 34703
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: "Sepia" adjustment not working right.

Post by xnview »

marsh wrote:Image>Map>Sepia... The slider has too limited range. 0 to -1.
Right i'll fix it
Pierre.
User avatar
Olivier_G
XnThusiast
Posts: 1423
Joined: Thu Dec 23, 2004 7:17 pm
Location: Paris, France
Contact:

Post by Olivier_G »

Works in v1.82.4 (slider & title)
Olivier
Locked