programmation album photos

Questions générales en Français

Moderators: XnTriq, xnview

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

programmation album photos

Post by claude gobez » Fri Aug 03, 2018 9:45 am

Bonjour

Je cherche à modifié le programme de la création d'un album photos.
J'ai réussi à programmé l'image de fond de la page html.
par contre le lien vers la page d'accueil ne fonctionne pas
un seul lien fonctionne pour les vignettes.
merci pour une aide
Claude

User avatar
xnview
Author of XnView
Posts: 30244
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: programmation album photos

Post by xnview » Sat Aug 04, 2018 9:14 am

il nous faudrait plus d'infos? quel modèle? qu'avez vous modifié?
Pierre.

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Sat Aug 04, 2018 12:55 pm

Bonjour Pierre,

Merci pour votre demande.

Dans le logiciel, il y à un fichier "Web Template" avec pour fichiers :

Default.css
Index.html
Page.html
thumb.html
UntileFrame-1htm

Dans le fichier "page.html" j'ai ajouté "accueil" ce lien qui ne fonctionne pas (à gauche de "précédent- prochain) et à droite des deux derniers "retour" retour aux vignettes lien qui ne fonctionne pas non plus.

Ci-dessous un lien sur le site, dont je m'occupe (bénévolement et en amateur et en autoformation en permanence pour une association loi de 1901) qui résume ce qui ne fonctionnent pas.

http://club-amis-meccano.net/Pages_gale ... index.html

Vous pouvez-voir "http://club-amis-meccano.net/Pages_gale ... index.html" un bon fonctionnement de la galerie. (je n'ais pas pu déterminé le problème pour une modification des autres galeries).

D'avance, merci pour votre aide.

Bien cordialement.

Claude.

User avatar
xnview
Author of XnView
Posts: 30244
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: programmation album photos

Post by xnview » Sat Aug 04, 2018 1:49 pm

sur
retour/acceuil fonctionnent bien
Pierre.

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Sat Aug 04, 2018 7:49 pm

Bonsoir,

http://club-amis-meccano.net/acceuil_Ga ... otos_1.htm

lien pour voir l'album n° 10 qui fonctionne très bien
Voir l'album n° 25 par exemple qui ne fonctionne pas du tout comme le n° 10.

par exemple un clique sur la première vignette mène à la première photo, un clique sur retour là cela fonctionne, à gauche liste des vignettes un clique sur la deuxième vignette là cela reste sans effet ainsi que sur les suivantes.

je me résume: pourquoi l'album 10 fonctionne et tous les autres ne fonctionnent pas comme le n°10 ?

j'ai enregistrer ce modèle de "Web Template" avec un nom spécifique pour justement avoir tous les albums pareils

merci pour votre aide

Claude

User avatar
xnview
Author of XnView
Posts: 30244
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: programmation album photos

Post by xnview » Sun Aug 05, 2018 7:54 am

La difference ne serait pas

Code: Select all

target="_self"
dans thumb.html
Pierre.

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Sun Aug 05, 2018 3:19 pm

Bonjour,

Ma réponse à votre interrogation
Image1.jpg
Le code est bien présent.
merci
Claude

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Tue Aug 07, 2018 12:52 pm

Bonjour,

après vérifications sur les autres albums le code est partout. target="_self" dans thumb.html

le problème n'est pas résolu.

merci pour une aide.

Claude

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Wed Aug 08, 2018 9:16 am

Bonjour Pierre,

j'ai changé de version du logiciel (v2.45).
j'ai un problème :
j'ai deux fenêtres erreur : il n'y à pas de thumb.html dans ce dossier modèle j'ai fais le nécessaire mais la fenêtre n'enregistre pas le nom du modèle
et la deuxième fenêtre est la suivante
fen_xn.jpg
fen_xn.jpg (55.62 KiB) Viewed 507 times
je ne sais pas quoi faire.

si vous pouvez m'apporter une aide
par avance merci

Claude

User avatar
xnview
Author of XnView
Posts: 30244
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: programmation album photos

Post by xnview » Wed Aug 08, 2018 11:42 am

quand avez vous ça?
Pierre.

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Wed Aug 08, 2018 12:04 pm

La procédure :
Je sélectionne les photos
Un clique sur page Web
la fenêtre"création page Web" s'ouvre (image 1)
je clique sur dossier modéle
Sur "C" dans le dossier XnView, je clique sur WebTemple
Un autre clique sur Défault-Frame
Ouverture d'une page (image 2)
Je clique select
S'ouvre la fenêtre (image 3)
Pierre_01.jpg
Pierre_01.jpg (53.38 KiB) Viewed 485 times
Pierre_02.jpg
Pierre_03.jpg
merci pour votre réponse

Claude

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Wed Aug 08, 2018 4:49 pm

La procédure :
Je sélectionne les photos
Un clique sur page Web
la fenêtre"création page Web" s'ouvre (image 1)
je clique sur dossier modéle
Sur "C" dans le dossier XnView, je clique sur WebTemple
Un autre clique sur Défault-Frame
Ouverture d'une page (image 2)
Je clique select
S'ouvre la fenêtre (image 3)
Pierre_02.jpg
The attachment Pierre_02.jpg is no longer available
[attachment=0]Pierre_03.jpg[/attachment

merci pour votre réponse

Claude

User avatar
XnTriq
Moderator & Librarian
Posts: 5319
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: programmation album photos

Post by XnTriq » Thu Aug 09, 2018 3:15 am

Bonjour, Claude. Bienvenue sur le forum.

thumb.html: <a href=”#FRAME_PAGE#” target="blank">

claude gobez
Posts: 13
Joined: Fri Aug 03, 2018 9:38 am

Re: programmation album photos

Post by claude gobez » Thu Aug 09, 2018 7:39 am

Bonjour XnTriq,

merci de votre réponse :

Si je vous ai bien compris, dans le fichier thumb.html il faut supprimé "target="blank">" ce que j'ai fais dans le répertoire de " C" qui contient le logiciel
la suppression à été faite via le logiciel Dreamweaver et non le bloc-note qui ma refusé la modif.

j'ai de nouveau fais un test, le problème n'a pas changer. la fenêtre dossiers des modèles est toujours présente.

je ne suis qu'un amateur en informatique merci pour l'aide que vous pouvez m'apporter.

Bonne journée

Claude

User avatar
XnTriq
Moderator & Librarian
Posts: 5319
Joined: Sun Sep 25, 2005 3:00 am
Location: Ref Desk

Re: programmation album photos

Post by XnTriq » Thu Aug 09, 2018 11:30 pm

p151429_1.png
http://www.club-amis-meccano.net/Pages_galerie_photos/25_Pelleteuse_Bessay-Bovas/index.html

Code: Select all

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN">
<html>
<head>
<meta name="GENERATOR" content="XnView">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="Content-Language" content="fr">
<title>Album_Besay/Bovas</title>
</head>

<frameset cols="20%, 80%">
	<frame src="thumb.html" name="frame1" frameborder="0" marginwidth="0">
	<frame src="UntitledFrame-1.htm" name="frame2" frameborder="0" marginwidth="0">
	<noframes><p>Il semblerait que votre navigateur ne supporte pas les frames,
	ou qu'il est configuré pour ne pas les autoriser.</p></noframes>
</frameset>

</html>



p151429_2.png
thumb.html

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
 "http://www.w3.org/TR/html4/loose.dtd">
<html>

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta http-equiv="Content-Language" content="fr">
<title>#TITLE#</title>
<link rel="stylesheet" type="text/css" href="default.css">
<style type="text/css">
<!--
body {
	background-image: url(image_fond_60.gif);
}
.Style1 {color: #000000;}
-->
</style>
<base target="frame2">
</head>

<body>
<h1 class="Style1">#HEADER#</h1>
<table cellpadding="5" cellspacing="0">
#THUMB_TABLE_START#
<tr>
#THUMB_ROW_START#
<td>
<a href="#FRAME_PAGE#"><img src="#THUMB_LINK#" alt="#FILENAME#" width="#THUMB_WIDTH#" height="#THUMB_HEIGHT#"></a>
<div>#THUMB_TEXT#</div>
</td>
#THUMB_ROW_END#
</tr>
#THUMB_END#
</table>
</body>

</html>

Post Reply