MP 0.39 (linux x64) crash on startup

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Post Reply
Roumano
Posts: 115
Joined: Sun Oct 10, 2010 6:20 pm

MP 0.39 (linux x64) crash on startup

Post by Roumano » Tue Sep 06, 2011 6:02 pm

Hi,

The 0.39 crash on startup :

## BROWSER RESIZE: 1111 342
I/O error : No such file or directory
/usr/share/mime/inode/directory.xml:1: parser error : Extra content at the end of the document

^
*** glibc detected *** /home/roumano/bin/XnViewMP-039/xnview: free(): invalid pointer: 0x0072002f0065006d ***

If i just do this, xnviewMP can launch correctly :

mv /usr/share/mime/inode/directory.xml /usr/share/mime/inode/directory.xml.old

( No problem with 0.35 version)

More information about this file :

cat /usr/share/mime/inode/directory.xml.old
<?xml version="1.0" encoding="utf-8"?>
<mime-type xmlns="http://www.freedesktop.org/standards/shared-mime-info" type="inode/directory">
<!--Created automatically by update-mime-database. DO NOT EDIT!-->
<comment>folder</comment>
<comment xml:lang="fr">dossier</comment>
<alias type="x-directory/normal"/>
</mime-type>

salvadhor
Posts: 5
Joined: Tue Sep 06, 2011 5:52 pm

Re: MP 0.39 (linux x64) crash on startup

Post by salvadhor » Tue Sep 06, 2011 6:08 pm

Very similar to:

http://newsgroup.xnview.com/viewtopic.php?f=60&t=21546

Maybe try the trick with the extra-libs...

User avatar
xnview
Author of XnView
Posts: 33488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP 0.39 (linux x64) crash on startup

Post by xnview » Tue Sep 06, 2011 6:51 pm

Add these libs in lib folder
Pierre.

Roumano
Posts: 115
Joined: Sun Oct 10, 2010 6:20 pm

Re: MP 0.39 (linux x64) crash on startup

Post by Roumano » Tue Sep 06, 2011 7:12 pm

Yes perfect ! Thx

Post Reply