problem with french accented characters in V0.39 beta

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Post Reply
Markorki
Posts: 91
Joined: Wed Mar 08, 2006 3:14 pm
Location: Grenoble
Contact:

problem with french accented characters in V0.39 beta

Post by Markorki » Thu Oct 13, 2011 3:42 pm

hello,

The new version is very much improved, and now almost as rich as V1.98.2 thanks for this good job !

There is though a problem of french characters. It seems to affects only (?) IPTC metadata


Image


This screenshot shows that "chène près du belvédère de Côte Rouge."
is displayed as "chne prs du belvdre de Cte Rouge" , which is more compact ;-) but not what i typed in.

This screen is different, with all characters OK (but shows a problem of refresh: recent subdirectory "conv" absent from tree panel, despite several "refresh" commands")

Image


Accented characters are ok in fields other than IPTC , such as directory path or "info" used in full screen display, as long as this "info" is not extracted from Iptc fields, as you can see in this small crop from a full screen display of a picture:

Image

corresponding to this option :

Image

My config : Ubuntu 10.04-LTS_64bits / Asus AMD-64_singlecore
Dommage, l'était sympa cette planète ;-(

User avatar
xnview
Author of XnView
Posts: 31488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: problem with french accented characters in V0.39 beta

Post by xnview » Mon Oct 17, 2011 8:27 am

Could you send me the picture file?
Pierre.

User avatar
Clo
XnThusiast
Posts: 4441
Joined: Sun Oct 17, 2004 4:57 am
Location: Bordeaux, France
Contact:

Aside---

Post by Clo » Mon Oct 17, 2011 11:26 am

:arrow: Pierre

:) Hello !

:shock: On the capture above we might read [Informations affichées]

:mrgreen: KR
Claude
Clo
Old user ON SELECTIVE STRIKE till further notice

Markorki
Posts: 91
Joined: Wed Mar 08, 2006 3:14 pm
Location: Grenoble
Contact:

Re: problem with french accented characters in V0.39 beta

Post by Markorki » Sun Nov 06, 2011 11:03 pm

Hi, Pierre

The picture is here :
http://sebmortum.free.fr/images_publiqu ... 939_xn.jpg
but the problem is with all my pictures with french text.

Do you suspect character encoding ?
Some of my pictures are IPTC commented using Exifer, some others with windows XnView, the problem seems to affect all of them.
Dommage, l'était sympa cette planète ;-(

User avatar
xnview
Author of XnView
Posts: 31488
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: problem with french accented characters in V0.39 beta

Post by xnview » Tue Nov 29, 2011 10:23 am

Désolé pour le délai de ma réponse. En fait, l'IPTC n'est pas en UTF8, donc il y a un probleme d'encodage.
Dans option>Metadata, changez pour windows-1252
Pierre.

Post Reply