XnViewMP on Suse Linux

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, helmut, xnview

mschnell
Posts: 6
Joined: Sat Apr 13, 2013 11:38 am
Location: Germany

XnViewMP on Suse Linux

Post by mschnell »

I d/lded the XnView TGZ file, unzipeed it and started the resulting xnview.sh script.

Seemingly the software was installed: I now see a .xnviewmp folder in my home directory and same contains the files xnview.ini and XnView.db.

The only xnview executable I find, still is "XnView" in the Download folder where I unzipped the tgz.

When starting same I get:

Code: Select all

.... lots of stuff ...
 CategoryNode::add : 0x8ba0ab8 to 0x8b9ef60
 CategoryNode::CategoryNode : 0x8ba0af8  All
 CategoryNode::add : 0x8ba0af8 to 0x8b9ef60
########### BrowserWindow :: restoreState (850 590)
BrowserWindow :: restoreState => 850 590 
                              => 591 250 
### MyBitmapView (8b3cec8) :: resizeEvent 367 240
BrowserWindow :: restoreState ok => 591 250 
### BrowserWindow :: onStart
BrowserWindow :: onStart 2
setPathname </home/mschnell/>
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
## OPEN FOLDER
## OPEN FOLDER ok
## updateLabels
## updateLabels ok
ThumbLoaderThread :: stop()
### ThumbLoaderThread :: stop() ok
./XnView: symbol lookup error: ./XnView: undefined symbol: _ZN6QMutex12lockInternalEv
What to do ?

Thanks,
-Michael
User avatar
xnview
Author of XnView
Posts: 43700
Joined: Mon Oct 13, 2003 7:31 am
Location: France

Re: XnViewMP on Suse Linux

Post by xnview »

which version of suse?
Pierre.