XnViewMP-0.60 : Drag and drop to LibreOffice - No news here

Ideas for improvements and requests for new features in XnView MP

Moderators: XnTriq, xnview

Post Reply
User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

XnViewMP-0.60 : Drag and drop to LibreOffice - No news here

Post by Elias » Wed Jun 19, 2013 1:36 am

I am using Chakra Linux 64 bits, LibreOffice 4.0.3 and XnViewMP 0.60.
When I try to drag and drop an image from XnViewMP to a LibreOffice document, I get an "Insert Section" dialog from LibreOffice and I can't insert the image.
When I try to drag and drop an image from XnViewMP to a Kate document I get a "The file or folder smb://####### doesn't exist" message from Kate and I can't insert the image.
It works perfectly when I use Windows 7 and I think it worked when I was using Kubuntu.
And what means the message "smb://" when the file I am trying to drag and drop is in my local disk?
Someone can help me to fix or understand this?
Attachments
XnViewMP-Kate.png
Trying to drag and drop a local image from XnViewMP to Kate in Chakra Linux 64 bits.
XnViewMP-Kate.png (81.95 KiB) Viewed 1206 times
XnViewMP-LibreOffice.png
Trying to drag and drop a local image from XnViewMP to LibreOffice in Chakra Linux 64 bits.
XnViewMP-LibreOffice.png (121.07 KiB) Viewed 1206 times
Last edited by Elias on Sat Jul 06, 2013 4:05 am, edited 1 time in total.

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: Drag and drop - XnViewMP => LibreOffice

Post by xnview » Wed Jun 19, 2013 6:53 am

The file that you drag&drop is on a shared folder?
Pierre.

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: Drag and drop - XnViewMP => LibreOffice

Post by Elias » Thu Jun 20, 2013 1:01 am

Hi Pierre. No, nothing special. The files are in normal folders in my HD.
I don't understand why the "smb://" appears. The files are in normal and common folders in a local drive installed in my PC.

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by Elias » Sat Jul 06, 2013 4:09 am

I updated to XnViewMP-0.60 with new drag and drop capacities.
I was happy. But my little problem remais the same.

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by Elias » Sat Jul 06, 2013 4:19 pm

I'm using Chakra Linux 2013.05-Benz, KDE 4.10.4, Dolphin 2.2 and XnViewMP 0.60.
When I try to drag and drop an image
from
/home/elias/images-2/LG-109.JPG
to
/home/elias/images/
I get the message
"O arquivo ou pasta smb://home/elias/images-2/LG-109.JPG não existe"
or in english
"The file or folder smb://home/elias/images-2/LG-109.JPG don't exist"
I'm sending a snapshot to ilustrate.
Thanks in advance.
Attachments
Drag and drop - XnViewMP - Dolphin - 2.jpg
Drag and drop - XnViewMP - Dolphin - 2.jpg (95.59 KiB) Viewed 1045 times

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by xnview » Tue Jul 09, 2013 8:06 am

And with another software than LibreOffice?
Pierre.

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by oops66 » Tue Jul 09, 2013 8:14 am

xnview wrote:And with another software than LibreOffice?
Hello,
FYI: Strange ... Drag and drop to "LibreOffice 3.5.7.2" works here. (from XnViewMP Linux x64 v0.60 under Ubuntu LTS 10.04)
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by Elias » Tue Jul 09, 2013 6:38 pm

Hi Pierre
As I posted on 06 Jul 2013, it's not working even with the official KDE file manager Dolphin.
oops66 wrote:FYI: Strange ... Drag and drop to "LibreOffice 3.5.7.2" works here. (from XnViewMP Linux x64 v0.60 under Ubuntu LTS 10.04)
And even more strange. I works perfectly on another machine runing Chakra Linux 32 bits.
The only difference I could note was: Working on a 32 bits machine - Don't working on a 64 bits machine.

PS.: And what about the mysterious "smb://" appearing in the dialog boxes?

User avatar
xnview
Author of XnView
Posts: 32285
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by xnview » Tue Jul 09, 2013 7:06 pm

Elias wrote: PS.: And what about the mysterious "smb://" appearing in the dialog boxes?
No :(
Pierre.

User avatar
oops66
XnThusiast
Posts: 1999
Joined: Tue Jul 17, 2007 1:17 am
Location: France

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by oops66 » Tue Jul 09, 2013 7:18 pm

Elias wrote:Hi Pierre
As I posted on 06 Jul 2013, it's not working even with the official KDE file manager Dolphin....
...So it's probably a system configuration problem ??? ... you should do a try with/from an other location like /home/$USER/folder1/file1.jpg ... ?
XnViewMP 0.82 Linux X64 - Ubuntu 16.04 LTS - X64

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by Elias » Tue Jul 09, 2013 11:04 pm

My dear (new) friend oops66, en fait, vous êtes probablement un génie.
Pardon, it's only a joke.
Well, I don't know how you did this but you are completly right.
I create a new user and tried to use XnViewMP to copy an image from a folder to another directly on Dolphin.
It worked!!!!
So I tried to copy from XnView to a document on LibreOffice and so....
It worked perfectly.

So I will have to abandon my normal user to fix the problem.
Thanks very much, merci bien, but...

What kind of @#%#$#$$##@@ configuration problem can cause this?

Elias

PS. I'm feeling happy cause there was no problem with XnViewMP at all.

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by Elias » Wed Jul 10, 2013 1:17 pm

But.... as the problem occurred only with XnViewMP (I think), it would be interesting to find out what happened?

User avatar
m.Th.
XnThusiast
Posts: 1575
Joined: Wed Aug 16, 2006 6:31 am
Contact:

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by m.Th. » Thu Jul 11, 2013 7:28 am

Elias wrote:But.... as the problem occurred only with XnViewMP (I think), it would be interesting to find out what happened?
Perhaps a problem in the smb.conf file?
m. Th.

The Ascetic Experience - The best photos and texts from Holy Mountain (Athos)

- Dark Themed XnViewMP 0.90 64bit & XnView 2.00 x64 on Win7 x64 -

User avatar
Elias
Posts: 39
Joined: Mon Jan 26, 2009 10:49 pm
Location: Brasil

Re: XnViewMP-0.60 : Drag and drop to LibreOffice - No news h

Post by Elias » Fri Jul 12, 2013 7:23 pm

I give up.
I tried all I could and nothing.
I created a new user and the drag and drop works... and so, suddenly stops working.
I created a new user again... and works again. I tried to isolate all possible parameters, from smb, from user, from XnViewMP, LibreOffice and nothing seems to explain when works and when stops working.
I tried to copy several parameters from a good user to a user that doesn't work... and nothing.
So, suddenly the good users stops working too, without any warning.
And... it's too much for me. I am not an expert, only a curious.
For while, no more drag and drop from XnViewMP for me.
I can't live without XnViewMP but I can live without this feature.
Thanks for helps. If someone find out something...

Post Reply