MP035 wont start on Debian/KDE

Bugs and Suggestions in XnView MP or XnConvert MP which have been resolved.

Moderator: XnTriq

Post Reply
ndani
Posts: 3
Joined: Wed May 18, 2011 8:45 pm

MP035 wont start on Debian/KDE

Post by ndani » Wed May 18, 2011 8:53 pm

Hi!

Code: Select all

bubu@bubugep:~/temp/XnViewMP-035$ ./xnview.sh
Cannot mix incompatible Qt library (version 0x40702) with this library (version 0x40701)
Aborted

bubu@bubugep:~/temp/XnViewMP-035$ ./xnview
./xnview: error while loading shared libraries: libQtWebKitXn.so.4: cannot open shared object file: No such file or directory

bubu@bubugep:~/temp/XnViewMP-035$ uname -a
Linux bubugep 2.6.38-2-amd64 #1 SMP Sun May 8 13:51:57 UTC 2011 x86_64 GNU/Linux

bubu@bubugep:~/temp/XnViewMP-035$ kded4 --version
Qt: 4.7.2
KDE Development Platform: 4.4.5 (KDE 4.4.5)
KDE Daemon: $Id: kded.cpp 1031637 2009-10-05 16:58:19Z lunakl $

User avatar
xnview
Author of XnView
Posts: 31264
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP035 wont start on Debian/KDE

Post by xnview » Thu May 19, 2011 12:59 pm

could you try:

Code: Select all

strace ./xnview |& grep -i libqt | grep -v XnViewMP
Pierre.

ndani
Posts: 3
Joined: Wed May 18, 2011 8:45 pm

Re: MP035 wont start on Debian/KDE

Post by ndani » Thu May 19, 2011 6:50 pm

Code: Select all

bubu@bubugep:~/temp/XnViewMP-035$ strace ./xnview |& grep -i libqt | grep -v XnViewMP
open("/lib/tls/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/tls/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/tls/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/tls/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/tls/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/lib/x86_64-linux-gnu/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/tls/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/tls/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/x86_64/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/x86_64-linux-gnu/libQtWebKitXn.so.4", O_RDONLY) = -1 ENOENT (No such file or directory)
writev(2, [{"./xnview", 8}, {": ", 2}, {"error while loading shared libra"..., 36}, {": ", 2}, {"libQtWebKitXn.so.4", 18}, {": ", 2}, {"cannot open shared object file", 30}, {": ", 2}, {"No such file or directory", 25}, {"\n", 1}], 10./xnview: error while loading shared libraries: libQtWebKitXn.so.4: cannot open shared object file: No such file or directory
FYI: Meanwhile I had reverted back to 2.6.32 kernel, but the above mentioned issue stayed the same.

User avatar
xnview
Author of XnView
Posts: 31264
Joined: Mon Oct 13, 2003 7:31 am
Location: France
Contact:

Re: MP035 wont start on Debian/KDE

Post by xnview » Fri May 20, 2011 2:27 pm

Sorry this one

Code: Select all

strace ./xnview.sh |& grep -i libqt | grep -v XnViewMP
Pierre.

ndani
Posts: 3
Joined: Wed May 18, 2011 8:45 pm

Re: MP035 wont start on Debian/KDE

Post by ndani » Sat May 21, 2011 7:44 am

Dear Pierre,

I'm really sorry, but since then I've changed Debian for Kubuntu (for other reasons) and the problem has gone. (KUbuntu has KDE 4.6.2)
In trying to help you, I've installed the same environment that I had before into a VirtualBox, but MP035 worked on that.
I'm really appreciate your work and I'm sorry that my bug report turned out not being helpful.

Daniel

Post Reply